Default Dsp Chain, Not Working?

I am trying to set a default DSP chain by right clicking in the Disk browser, selecting “Load file with options” and ticking “Use as default”.

I expect this to use the same DSP chain everytime i insert a new track (ctrl-t). This is not the case.

Am I doing something wrong? (using renoise 2.7b1 which is just great)

PS. It would be better if also the pre-fx parameters (like “routing”) could be saved to a default track template.

Can anyone confirm that i understood this feature correctly, and that it is a bug?

This feature is not designed to do what you think.

When importing a DSP chain you have two different possible methods:

  • Replace existing chain: All devices in the current track’s DSP chain will be cleared before loading the new DSP chain.
  • Do not replace existing chain: The loaded DSP chain will be appended/merged to the end of the current track’s DSP chain.

This option is usually toggled via: Preferences > Files > Device Chain Import > Replace Existing Chain

When you use the Disk Browser and you choose ‘Load File with Options’, then you can also temporarily override this preference from the dialog box that appears. The ‘Use as default’ checkbox allows you to replace the default setting in the Preferences screen. It’s just a convenient alternative so you don’t have to go back into the Preferences every time.

Thanks for the clarification dblue. It was easy for me to misunderstand the label of the tick, but now it is clear.

A workaround for the feature i am requesting could be to set Track 01 the way I want a default track, and then use “duplicate track” on Track 01 everytime i want to insert a track.