Disable chapters on wavefile output?

Long time user, but rarely post here.

I just did a bounce in Renoise 3.3 and notice it’s now adding chapter markers to the wave file per pattern. This looks like a really cool feature for some use cases, but it’s making encoding with ffmpeg more complicated. Is there a way to disable adding chapter markers?

Thanks!

I’m sure that rendering cue information has been with Renoise for quite a while under ‘Hidden Rendering Feature’(?) https://tutorials.renoise.com/wiki/Render_Song_to_Audio_File

Not as I know of.

If ffmpeg doesn’t write out a cue chunk into a wav file maybe you could run first(?):

$ ffmpeg -i Renoise.wav Renoise_nocue.wav
2 Likes

Hmm, I did upgrade ffmpeg recently. It’s possible that I was sitting on an older version that didn’t support the cue markers on wav files.

Regarding that command, it looks like simply reencoding will still pass through the cue markers. It looks like -map_chapters “-1” might be what I want, although there are other metadata manipulation options I need to look at. For now, I’m passing my bounce through Audacity to clear out the cue points.

Thanks for the response!

I can only tell you what I get with my version of ffmpeg. I just tried it (for my own sanity) here and I don’t get any cue information chunk passed through with my ffmpeg command (certain loop point info chunk isn’t preserved either if it was a looping sample). So I don’t know, I can only go by what my machine here shows me with a hex dump of the file.

1 Like