Discodsp Releases Discovery On Linux


I just noticed, that DiscoDSP has released Discovery softsynth on Linux, marking the first commercial VSTi release on linux. It seems to work very well with Renoise 2. I have only demo version of the plugin, but as it costs $99 I am considering to buy it aswell. We’ll see.

Anyone else has tried it yet? What’s the experience?

wow this is some good news really! it seems to be quite a reknown plugin and it is also great that commercial VST’s are entering the world of Linux.

well, from my point of view, of course…

Reading the mailing lists, forums and chat discussions, seems that Renoise has had some effect on overall adoption of Linux as audio platform. Behind this current release is probably dude named kraken/gore though.

Kraken is reknown for porting other VST’s to Linux and he is also a Renoise user, so this closes the circle :)

I just tried the demo version with renoise v1.9.1 and v2 beta and each time I tick to enable vst plugins in the preferences it crashes renoise as it scans. I placed the plugin in my home/.vst/ folder and I’m running ubuntu studio.

Any ideas?

Does this plugin crash renoise or maybe some other?

I don’t have any other plugins, so it has to be this one.

From CachedFailedVsts.xml :

<failedaudioplugincache doc_version="1"><br>

Which Distribution are you running, which version? 64bit or 32bit?

You can also check the output of: ldd /home/user/.vst/DiscoveryDemo.so

Ubuntu Studio 8.04, 32bit.

 linux-gate.so.1 => (0xb7f85000)  
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6477000)  
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb645f000)  
 librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb6456000)  
 libX11.so.6 => /usr/lib/libX11.so.6 (0xb636f000)  
 libGL.so.1 => /usr/lib/libGL.so.1 (0xb62cb000)  
 libGLU.so.1 => /usr/lib/libGLU.so.1 (0xb6248000)  
 libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb6244000)  
 libasound.so.2 => /usr/lib/libasound.so.2 (0xb6181000)  
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb608e000)  
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb6069000)  
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb605e000)  
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb5f0f000)  
 libz.so.1 => /usr/lib/libz.so.1 (0xb5ef9000)  
 /lib/ld-linux.so.2 (0xb7f86000)  
 libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb5ef7000)  
 libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb5edf000)  
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb5edb000)  
 libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0xb53c6000)  
 libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0xb53c3000)  
 libXext.so.6 => /usr/lib/libXext.so.6 (0xb53b5000)  
 libXau.so.6 => /usr/lib/libXau.so.6 (0xb53b2000)  
 libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb53ad000)  

Oh, did you copy the other folder in the zip file to your home directory as instructed by install.txt?

If you did you may consider filing a bug report.

wow. I’ve just tried the demo version with renoise 2 (beta) for linux and this thing sounds really good. I’ll definitely buy this synth.

Thanks for the tip.


Hmmm… well it was late last night when i tried it, I remember opening the install.txt file, but may not have read it very well… I’ll check when I get home. I think I left the dir in the .vst folder :wacko: thanks for helping me despite my stupidity!


I just moved the folder to the right place and it still crashes both renoise 1.9.1 and v2. I’ll contact discodsp about it. Thanks for the help…

I’ve only got problems when renoise tries to release the plugin (when closing the track or the application).

The log just says:

Renoise LOG> VstPlugs: Releasing /home/gb/.vst/DiscoveryDemo/DiscoveryDemo.so...  
!! killing thread by force !!  

I have to kill the process by hand then.


This is known bug with JUCE plugins. Taktik can’t repeat it, but the report is here:


Awesome move, and a brilliant synth! Works great in the 2.0 beta, but it uses fairly much cpu power on my dual core laptop…

What’s the cpu usage for other peeps that have tested it?

Not that much, but not that little either. If you enable the oversampling then it takes bit more than my computer can handle per voice.

hopefully this will start a trend - there are so many plug ins i would like to see on linux