[done] MIDI Chord Mode: Behaviour When Replacing Notes & Prehearin

I’m not sure exactly when this occurs, but sometimes when I am in step recording mode (i.e. not recording along to playback), attempting to replace the note under the cursor with a MIDI-entered note causes the new note to be added in an extra column as a chord, rather than replacing the note. At other times, the replacement happens as expected.

Whatever causes the different behaviour, it is not dependent on whether the previous note has a NOTE-OFF command or not, and doesn’t seem to be linked to the selected instrument either.

Update: I’ve found what causes it: it is dependent on whether anything is currently playing through the speakers at the time (i.e. the decay of a previous note).

So the behaviour I see is:

  1. Enter a note to replace the existing note – replacement happens OK.
  2. Cause a long note to be played, such as by hitting ENTER to play the current line, or turning off edit mode and playing a note on a instrument with a long decay.
  3. Wait for the sound to die down.
  4. Repeat step 1. This time a chord is added.
  5. Wait for sound to die down again.
  6. Press SPACE. Nothing appears to happen, but internally the silent “sound” is stopped.
  7. Repeat step 1. Note is replaced.

Ledger already wanted to have this behavior changed during the alphas.

When starting to play something in the pattern via hitting return + stuff, then entering notes with the MIDI keyboard, chord mode will skip such already playing columns.

This might be a bit strange, but is this a “real” problem or a just a theoretical one? Aka is this really worth to be fixed? This can not easily be changed.

I only reported it because it kept getting in the way of my editing, so it’s certainly not just a theoretical problem.

If this is difficult to fix, could we perhaps have a toggle to disable the processing of note lengths altogether when entering chords? A lot of the time when I am recording I don’t care about note offs, and I never care about them when step editing.

I know you can disable the capture of note off events altogether in preferences, but I’m talking about an accessible toggle on the screen which can quickly switch on or off note length processing (there are some situations where I do want them). Perhaps in the location that the old “Chord mode” button would have been, if it still existed?

So the behaviour would be:

  1. Note-off recording ON: same as now.
  2. Note-off recording OFF: Note off events are never recorded, new notes ALWAYS go into the current column even if a previous note would have been playing, new columns are ONLY created if needed because of the number of simulaneous KEYS held down (not including previous sustained notes).

I can not promise that I’ll be able to change this in this beta. Let me put this to my feature request & finetuning TODOs please…

OK, thanks for considering it.

Lets try this:
Notes entered via the MIDI keyboard will now simply ignore already playing notes. So notes are not magically “auto-placed” then…

If this is as I imagine, it sounds great!

thanks taktik

So does this mean that chords are only added either with Shift+keys (for the computer keyboard) or whenever an additional note-signal through midi is being send simultaneously with other currently pressed notes?

I think this would solve the problem for me.
we will see in the next beta

Sounds great. Thanks so much :D