Double VSTi in list

Try to do (windows 7 x64, renoise 3.0, on x86 system THERE NO BUG)

  1. open combobox with plugin instruments
  2. in search line type 3 letters of plugin i need (deputy64 in my case). thereby is ONLY one plugin that i need (if there more then one plugin - no any bugs further)
  3. select plugin
  4. select next instrument slot
  5. open combobox with plugin instruments
  6. my plugin is appear twice (and with alias of previously choiced - triple)

ps There another little bug - on RECORD ON mode just play (don’t store on track) notes played from pc keyboard. But i can’t reproduce it. I think it was after detach sampler on other screen.

Can anyone confirm this behaviour?

Probably there are two deputy64.dlls in your VST folder?

No. It’s happens with other VSTi too. And only in x64 version.

May be it helps - this bug aplies only to VSTi that has “64” or “x64” at the end of a name. I’d check “cachedVSTs.db” and there no any duplicates. By the way - great thanx about this sql database, coz it’s very suitable to replace x86 -> x64 plugins with manual fixing this file. No one of DAW have not the same possibilities :slight_smile:

By the way - great thanx about this sql database, coz it’s very suitable to replace x86 -> x64 plugins with manual fixing this file. No one of DAW have not the same possibilities :slight_smile:

Ehhm. Maybe that’s what has broken it? Please let us know what exactly you’ve changed in there.

Fix some “DocumentIdentifier” values. After migrate to x64 system, replace some VSTi with x64 versions. The name of plugins was changed. For example - in x86 system the DocumentIdentifier was “Albino 3”, after reinstall - “Albino 3 x64”. Open CahedVST with “SQLite Database browser” and change “Albino 3 x64” -> “Albino 3” instead of fix several XRNS used this stuff. Coz the XRNS say “The plugin not found”.