Duplex Beta Versions

Excuse me i was wrong, it’s not the 0.98b11 (i had not try this one) but 0.98b10 where mixer works but in birectionnal mode and i had to move faders on the mackie control hardware from up and down to duplex catch the position…

[s]Hi danoise,

I used the keyboard device for mapping pitchbend and aftertouch to midi cc#108 and #109. It worked good. But now after some restarting, the remapping just does not work anymore, no matter if I disable and reenable the keyboard device in duplex or not, filter pitchbend or not in Renoise settings.

The midi mapper just does not recognize the remapped parameter anymore. I restarted Renoise several times and also tested it with a new song. It just does not work anymore. What could cause this?

The duplex device view still shows the movement of the pitchbend slider, if I move the remote stick on the M3. So something goes wrong with the remapping I guess.[/s]

Sorry, The OSC server was accidently disabled after Renoise crashed, that’s way the mapping didn’t work anymore.

danoise, please check also my bugreport here, regarding the pitchbend at 1% when control is untouched. I don’t know if it’s renoise related or your parameter conversion should be fixed…

Boom!! Duplex 0.98b15

Another update, containing voice-manager/MIDI mapping- related enhancements and bugfixes.
Upgrading is recommended :)
Download link has been updated and SVN too.

So, I’ve been working on making the voice-manager as solid as possible. The Keyboard application will benefit from this, as you can now select between three modes:

  1. Trigger notes in range (OSC)
  2. Trigger all (range as OSC, others as MIDI)
  3. Trigger nothing (disable)

(1) is the standard mode, and will simply trigger notes within the range (which, by default, is the entire keyboard)
(2) will allow the notes outside this range to be passed into Renoise (they are passed as MIDI, which means no instr/track routing)
(3) will allow you to shut down a Keyboard application. Useful e.g. when you have multiple keyboards and (temporarily) want to ignore one of them.

Even though we are now dealing with both OSC/MIDI-triggered notes, the issue of “stuck notes” should be completely gone.

Here’s the full list of changes & additions:

– Duplex core API –

  • MIDI pass-on: allow native MIDI mapping for unhandled parameters
  • MIDI pass-on: virtual control surface able to generate MIDI
  • MIDI pass-on: all UIComponents can “actively reject” an event
  • Control-map: MIDI channel support for keyboards (specific/any channel)
  • Control-map: pitch-bend mappings receive + send
  • New class: OscVoiceMgr, provides voice-management features
  • Device-config: hide specific application options (hidden_options)
  • Fixed: choosing “cancel” when shutting down devices would throw an error
  • Fixed: proper access to document nodes (.value)

– Applications/XYPad.lua –

  • Fixed: No longer looses focus when navigating to a new track

– Applications/Keyboard.lua –

  • New option: “Keyboard Mode”, choose which notes (if any) to trigger

– Device configurations-

  • Extra device-configs for AkaiLPD8, APC20 + APC40

Could you check if it’s working now?

It’s out: Duplex 0.98b16. Download link located here.

– Duplex Core API –

  • OscClient.lua:one-time instructions on how to enable the OSC server

– Applications/GridPie.lua –

  • Feature: “Running start” (smooth transition into Grid Pie’d mode)
  • Feature: “Keep the beat” (try to maintain beat when pattern length changes)
  • Fixed: poly-meter computation (too few values considered)

Read about the new grid pie features in it’s dedicated topic :slight_smile:

Lights for the clips in GridPie are not working correctly on my Monome with b16. They stay switched on when I turn clips off, and perhaps some weird stuff when paging downwards. I can give a more detailed report if you like. I went back to b13, the latest of the previous versions in my downloads folder.

Thanks, I can see the issue popping up in a number of places on the monome. Will investigate…

Not really necessary, but it would be great if you could test the fixed version (I’ll release it tomorrow)

Which I obviously didn’t

But it seems to be working here, it just got caught up in the next round of re-factoring.

The 17th beta of Duplex 0.98 has arrived …But what’s in a number anyway?

the main feature is mostly relevant for for programmers: three button types are gone, in favor of just one: the all-mighty UIButton.
If you’re actually writing scripts, having just one button type greatly simplifies how to display “stuff”.

I made this as well:

The new display combines text & color. It works like this:

  • devices with no text get text, devices with no color get color.
  • devices that have a specific color-space will still be restricted to the allowed range

– Full release notes –

Duplex 0.98b17  
* Refactoring: UIButton (replaces UIPushButton, UIToggleButton,  
UIStepSeqButton). All applications have been updated to use of the new UI  
* UIComponent events, fix issues with MIDI message passed on to Renoise  
* Virtual control surface able to display text & color simultaneously  
* Theming support: specify the default button color (default is white). No UI is  
provided for changing the value, so in order to match Duplex with your own theme  
color, modify the value in Globals.lua (search for “theme”) and delete your  
preferences before restarting.  
* Light up arrow only if next/previous config is available  
* Stop scheduled blinking when current pattern is re-scheduled  
* remove “invert” option in favor of customizable palette  
* fixed a bug when switching away from Grid without having run the application  

Download is located in the first post

Does anyone know how to load Remote-SL-MKII.automap using Automap 4.2?


It’s simple: open the auto mapping dialog (press “view” on the device when AM is running), and click “open” in one of the topmost buttons. Then navigate to the file…
Another way to open the mapping dialog - in the automap software - is to go to the device list, select the remote and click “edit mappings” (or something similarly named)

However, Automap has been buggy with Duplex since v3.7. Some buttons does not update, it’s recommended to stick with Automap 3.5 (Novation has been informed about the issue).

It’s applicable to Automap 3.x but unfortunately not to AM 4.x. It doesn’t see Duplex as software client. Any thoughts? Or should I stick with 3.x version? I think if it’s not only my problem it’s worth to be mentioned in the list of supported controller.

Duplex never was, or should be listed as a software client. If it’s about DAW integration, then Duplex in itself represent an improvement over Automap (except perhaps the VST instrument mapping part), as Duplex “knows” Renoise inside out, and doesn’t have to care about how other DAWs work.
Basically, I only use Automap because it gives us the ability to set the lights on the Remote (in the normal MIDI mode, for some reason we can only receive messages from the device and not set lights).

Ah, but it already is. I just checked

Ok. I see. But the problem is that I can’t run Duplex with Automap 4.2 because I can’t find the way to load Remote-SL-MKII.automap file.

Anyway I’d like to say thank you danoise for such impressive extension for Renoise. I had a chance to play with it when AM 3.x was installed. ;)

Somewhere, somehow you must be able to display this? Then click “Open” in the topmost row…

Got it! Thanks! It was needed to enable any MIDI channel in AM 4.2 software and then it was possible to recall that screen.

I use Launchpad Matrix+Navigator+Transport and I still manage to break the block loop function.
to recreate:
play a song, activate blockloop by pressing the most right grid buttons (I tested with row of 1,2 and mostly 4).
now go a little berserk with the positioning of the block loop. eventually the loop won’t respond anymore and the song will continue normally.
while blockloop is still enabled in Renoise and according to the visual feedback on the Launchpad.

Not sure it’s a bug in Duplex or in Renoise.

I’m aware of a few quirks in the Navigator. But I couldn’t reproduce the problem by following those steps…

Some questions (perhaps you can remember the answers…):

  • How long was your pattern(s) ? Some pattern sizes (when not a power of 2) can cause problems with Renoise’s blockloop feature.
  • How large a blockloop did you create? (On the Launchpad, that would have to be between 1/8th and 1/2 a pattern).
  • Did you move the blockloop around by quickly pressing and releasing, by holding the button, or by resizing (pressing multiple buttons)?
  • Did you use Renoise to control the blockloop, or only the Launchpad?

You’re right, faders doesn’t seem to transmit anything.

Edit: I think I know what causes it: the following line from BCF-2000.lua :

self.loopback_received_messages = false  

Could be replaced with this line (or simply removed):

self.loopback_received_messages = true  

So, what does that line do? It basically disables the bi-directional feedback for the BCF-2000.
Had to do with how the faders didn’t always set themselves in the correct position, but with a properly working unit it should no longer be a problem.