Duplex Beta Versions


(danoise) #381

This is strange. I just tested with my Remote SL, and here it works fine (on pads, buttons and sliders).
Are you sure that you have de-selected your controller from the MIDI input in the Renoise prefs? When running Duplex, you need to let it take over control…
If this is not solving your issue, you could perhaps share the configuration, allow me to take a closer look?

I guess you want something like the Effect, but with the ability to display specific device(s). Ah yes, this is why the roamingDSP class was invented - I too needed a way to lock mappings. Not sure how to best deal with this, but let me think about it.

Btw: Very nice & sturdy looking controller. Congrats!


(re.dread) #382

i deactivated all midi inputs in the preferences, issue remains.
it’s not completely consistent actually, sometimes i get midi notes from the mute buttons eg, sometimes i don’t.
what allways ‘works’ is the pitchbends (the motor faders are assigned to pitchbend messages atm, i will change that soon-ish) … they do send pitchbend values to the current instrument.
config is still quite a mess: http://pastebin.com/JpKZLLfi controlmap: http://pastebin.com/txM8BMmu
renoise 3b7


(RANSOM) #383

Here is a nasty situation:

macbook pro running osx 10.9.2 + r3b7, also ipad4 on iOS 7.0.1

I’ve installed duplex for renoise and touch osc for iPad (also installed renoise template for touch osc iPad), I’ve checked all the ports/firewalls/setting in and out, BUT HERE IS THE STATE: touch osc on iPad is receiving states from Renoise, it means if i do something in renoise/duplex on mac i see how the sliders/encoders and buttons work on touch osc iPad = means touch osc receiving everything from renoise.

If i try to move slider/push buttons/ rotate encoders on iPad , i see signals going out of touch osc , but nothing happens in Renoise at all.

Please, can anyone help me with this? What am i doing wrong here?

@danoise PLEASE!

here is some screenshots btw

https://dl.dropboxusercontent.com/u/14951157/pics/Photo%2018-03-14%2001%2006%2025.jpg
https://dl.dropboxusercontent.com/u/14951157/pics/Photo%2018-03-14%2001%2006%2036.jpg
https://dl.dropboxusercontent.com/u/14951157/pics/Photo%2018-03-14%2001%2006%2049.jpg
https://dl.dropboxusercontent.com/u/14951157/pics/Photo%2018-03-14%2001%2007%2007.jpg


(danoise) #384

From what I can gather, you’ve set the IP address (‘host’) to the same IP address as your iPad. This should be the IP address of your Mac?

To see the IP address of your Mac:


(danoise) #385

Hmm, in the config file I can conclude that you are referencing a device class ‘MidiboxDC’ - but you haven’t linked to this file.

It looks like you are basing it off the Mackie-Control class? That would explain using pitch bend for faders, I guess :slight_smile:


(RANSOM) #386

THANKS A LOT! SOLVED ^______^


(re.dread) #387

Yep, i started with the Mackie-Control class & config.

class "MidiboxDC" (MidiDevice)  
  
function MidiboxDC:__init(display_name, message_stream, port_in, port_out)  
 TRACE("MidiboxDC:__init", display_name, message_stream, port_in, port_out)  
  
 MidiDevice.__init(self, display_name, message_stream, port_in, port_out)  
  
 self.allow_zero_velocity_note_on = true  
end  

I do actually get pitchbend values sent to the instruments when i run the mackie config too. With the ‘pass unhandled MIDI to renoise’ option enabled, that is. That would suggest that the forwarding does happen in Duplex somewhere i suppose?


(urbster1) #388

Tried to install the new Duplex for v3 but got this error, what should I do? Running Windows 7 x64. Thanks!
edit: added GlobalMidiActions.lua to Scripts folder, currently getting these 2 errors now


(danoise) #389

Thanks for the heads-up. I need to take a closer look at the MidiActions application - however I couldn’t recreate your bug.
In fact, I am not really sure what the bug is blink.gif

Tried to install the new Duplex for v3 but got this error

Could you please share the error message again (I guess you edited the post since it first appeared) ?
Otherwise, I don’t really know what to look for…

edit: added GlobalMidiActions.lua to Scripts folder, currently getting these 2 errors now

Hmm…you seem to have copied an old/obsolete version of those files - UPPER_FRAME_DISK_BROWSER was removed in 3.0, and shouldn’t be part of the Renoise resources anymore. Perhaps you didn’t uninstall last beta before installing new one?

To save you from a reinstall, try downloading these newer versions of the global MIDI/OSC scripts:
https://www.dropbox.com/s/rzwgi7yucpjphkl/GlobalActions_3.0.zip?raw=1


(urbster1) #390

Thanks danoise it’s up and running now!


(GhostofJohnToad) #391

On my win7 x64 boot using Renoise 3.0 with “com.renoise.Duplex.0.98.32.xrnx” I am getting this error… I tried replacing the GlobalMidiActions.lua with the file from another post but no luck. Using my linux boot with exact same renoise and duplex version no problems whatsoever. The location in windows on my machine is: “C:\Program Files\Renoise 3.0.0\Resources\Scripts” but in the error duplex appears to be looking for “C:\Program Files\Renoise 3.0.0\Scripts”

[edit] ah, yes that was it. I copied the scripts folder up a level to right under Renoise 3.0.0 and duplex fires up. So the install directory of the scripts changed in the new version from 2.8?


(vV) #392

Did you uninstalled Renoise 3.0 Beta/RC before installing Final?
The scripts run from c:\Users[yourusername]\AppData\Roaming\Renoise\V3.0.0\Scripts\
There you should also have the GlobalMidiActions.lua. If there is something corrupt with that file, Renoise might nag about it. Copying the original version from the C:\Program Files\Renoise 3.0.0\Resources\Scripts location to the c:\Users[yourusername]\AppData\Roaming\Renoise\V3.0.0\Scripts\ folder should then solve the problem.


(GhostofJohnToad) #393

I’ll make sure to do a clean-up just to make sure. I had previously un-installed the last 3.0 beta prior to the release 3.0, but not sure if I un-installed previous betas. That could be it. Thanks!


(danoise) #394

No, I have found the problem. It appears on Windows when you haven’t defined any custom GlobalMIDI/OSCActions file, and it then tries to load the “factory default” one.
Will be fixed in the upcoming release. Until then, copying the files previously provided into %appdata% should fix the problem


(pigdogs) #395

Same issue here even after doing what was said before.
Please help.

4909 error.jpg


(danoise) #396

Sorry for that - the MIDIActions application seems to cause trouble much too often.
I need to make it less prone to errors on startup, stay tuned for a new version soon…


(pigdogs) #397

Thanks Danoise. :)


(Thrashie) #398

Created “C:\Program Files\Renoise 3.0.0\Scripts” and copied both .lua files to it and problem solved for me… so thnx for that :)


(pigdogs) #399

Did the job for me too. The Mackie is now back in action. Great work.


(Goreteks) #400

Just want to say thanks to danoise for making this, i’m fairly new to renoise and know basically nothing about coding, but was able to get most of the way through mapping my Livid Code to my own .lua script after a few hours of self-education last night.