Echo Indigo Asio Problem

I’ve searched and not finding the fix.

I just installed Echo Indigo and ASIO is not working properly in Renoise 1.9.
I get sound, but the song loaded does not play at the correct speed.
I have the current Echo driver.
What am I doing wrong?

From edit-preferences:

Device Type ASIO
Sample Rate 44100 (I tried changing this, does not fix problem)

Did you installed the latest DirectX?

Reinstalled latest DirectX, did not fix problem.

I have version 6.14 working perfect here with Renoise, what does the rest of your setup look like?

Echo Indigo IO working fine here with renoise 1.9.
IBM thinkpad t30
win xp sp1

Now you mention it I have seen some strange samplerate behaviour with it, but only in adobe audition - it’s always perfect in renoise.

Are there any other programs running that might be routing stuff through the card on a different channel?
If I’ve got renoise running, I can’t get any sound out of winamp for example.

I know these indigo cards seem to be somewhat troublesome…
These problems keep popping up on occasions.
Is it a PCMCIA card?…hlite=%2Bindigo

Pentium 1.73 Ghz, 500 ram, Win XP. No other programs are running. Echo driver 7.3.

I think it has to have something to do with the sample rate, as I said I get sound but song doesn’t play at the correct speed.

Is your samplerate in your soundcard configuration locked? (e.g. locked to 48 / 88Khz or 96Khz)
This might be one of the problems.
Or that the bitrate is locked to 16, though i would expect the Indigo to play the samples slower if that was the case (playing 32 bit at 16 bit rate is two times as slow)

How do I check this?

It depends on what configuration software your audiocard manufacturer delivered.
Usually it is a separate mixing application that you call up from within the Windows configuration folder or it is installed in the programs folder most likely under the name of your manufacturer or the name of the soundcard.
In there you have the ASIO control panel for instance and there you could set the buffersize, sample-rate etc.
Though if this one is locked to a different rate than in Renoise, this could cause those problems.
In Renoise you can also call the control panel of your asio driver, but it nesessarily may not allow changes while the active host using the driver, has locked the ASIO driver.
So in some cases you have to close Renoise before applying changes and then reopen Renoise,
I have to deal with this process with my own soundcard.

Older topic here, but I still can’t get ASIO to work. I do not believe it to be Renoise related as I get the same problems in Torq when trying to use ASIO. It has to be Windows related.

Direct sound mode through my Echo Indigo plays normal.
ASIO mode plays audio but sounds low bit rate and crackles.
I’ve messed with all the settings in the Indigo software and had no luck yet.

Can anyone offer suggestions?

[strike]try setting the stuff for windows sound system thing to the thinkpads onboard soundcard, so that windows isn’t *icking with it :)[/strike]

er sorry, i assumed this was the pcmcia card in a laptop, suggestion may still work if mainboard has onboard sound?
;X - i confused myself with this post and another.

so if that doesn’t work for you, you could aways try the hardware stuff too, like putting the card in a different slot on the mainboard.

can also switch priority to background services, other than the usually set applications priority.
this will give more priority to you, sound system, but might make the graphics sticky.
nevertheless it’s worth trying.

-taken from another site-
Right click on My Computer and go down to Properties.
Click on the Advanced tab at the top of the screen.
Under the Performance section, click on Settings.
Click on the Advanced tab.
Under Processor Scheduling click on Background Services.
Click on Ok then Ok again

Have you already contacted the Echo Indigo support? They might help you to get this thing working…

Under the Edit>Preferences>Audio there is the “Limit to Stereo In/Out” box.
Is this a renoise function or does checking this box comunicate (adjust settings) with the ASIO driver/control panel settings?

This disables (better said does not enable) the drivers channels, so yes, this communicates with the driver…

Sorry, I don’t quite understand the “not enabling the drivers channels”.
Is the sound card still running in ASIO mode when this is checked?

Thanks for the help taktik.

Yes, of course its still running in ASIO mode. This mode simply only enabled the first ASIO channels of your driver…

Could the Echo Indigo support help you?

Somewhat, after changing multiple pc settings/driver etc. With that “Limit Stereo” box checked the card seems to work in Renoise now. If the box is unchecked I have the same problems in Renoise and in TORQ. Thats why I was asking if that box was affecting the driver/control panel settings.

Thanks again.

Sorry, can’t let this thread die as it still is not working right.

I am using the Echo DJ which has two outputs, headphone and line. When in Direct Sound mode I get the option of selecting which outputs to route through.
When I am in ASIO mode I do not get this option.
Is this right? Is this a Renoise issue or a Echo driver issue?
Anyone else using the Echo Indigo DJ and Renoise?