Enable granular selection by default (or tickbox in preferences)

First, thanks thanks for the granular selection! It doesn’t seem to work from keyboard (shift+arrows) on OSX but it works with mouse (option+drag), maybe I’m doing something wrong?

As granular selection is so much better I would prefer it to be the default without any modifier keys. Or at least have a tickbox in the preferences to enable this behaviour. In this case the old select everything would be done with modifier keys.

I still want to edit octave separately from the note like in IT though, is this hard to enable?