Energyxt Midi-data To Pattern Editor?

Is it somehow possible to grab the MIDI notes generated from eXT (being run inside Renoise as a VST rather than a stand-alone), so that one can record them – i.e. make them appear as notes in the tracker’s pattern editor?

Maybe this is a really stupid question. However, I was so amazed that eXT could do some other really cool stuff within Renoise (especially some routing issues), that I now thought: “maybe some wizard out there has found a solution to this as well, via some virtual midi-cables hooked up with a plug-in that is still unknown to me…”. Well, one can always try… :slight_smile:

i really dont think you can make eXT notes appear in renoise pattern editor… But why do you want that anyway?

I guess you could use some virtual midi-cables or something to record midi-notes from energy to renoise … but I am not sure about that and I am too busy making a 15 min minimal tech song to check that out right now. :blink:

Ooops. I really meant the other way around, of course, i.e. the notes should go from Renoise into XT. So the real question becomes: how do I get the notes in Renoise’s pattern editor to the sequencer in XT?

What I want with all this is to save .MID-files for export into Cubase or Logic. XT can do that, but then I have to enter the goddamn notes via that annoying piano-roll in XT that I sought to avoid by using a tracker in the first place!

no, you can use cubase or logic or whatever and renoise, use a virtual midi cable to connect renoise to cubase, make all your instruments in renoise “MIDI-Instruments” and hit record in cubase and play in renoise.

the off-bpm problem will be nasty, but it should work this way. done this with live and renoise, to get small loops into live.

  • Load XT as an instrument
  • Set up a sequencer in XT
  • Sync the sequencer to external
  • make sure midi track is hi-lited in XT
  • press record in XT seq.
  • press play in renoise

A midi clip should occur with the data from renoise in XT. You will have to do this one track at a time however…

It can also be done the other way around; I suggest using Jthalamus to get MIDI data out of an instance of energyXT inside renoise and directed towards a MIDI port that renoise is listening to. MIDIYoke and MIDIOx are handy in doing this. (Jthalamus can also be used to get MIDI data inside of an energyXT instance inside renoise from an external MIDI controller or sequencer, bypassing renoise).

Why bother? Why not run energyXT standalone alongside renoise? Well, this way they’re synced, so you can hit play+record in renoise, and record the MIDI data from the energyXT sequencer (or some other step sequencer energyXT is hosting) into renoise’s pattern editor without latency or sync problems.

Thank you, Ledger! Now it works fine.

Thank you, rounser! I immediately downloaded the Jthalamus VST and began experimenting. But this seems to be quite difficult to setup properly. How is your configuration here?

Please correct me where I go wrong:

  1. I load eXT as a VSTi inside Renoise, and load Jthalamus VSTi inside eXT.
  2. I configure Jthalamus “Input ->” to have MIDI device unchecked, VST BUS unchecked and Recive MIDI from host checked.
  3. I configure Jthalamus “Output ->” to have MIDI device checked and set to “MIDI Yoke NT: 1”. VST BUS and Send MIDI to host are both unchecked.
  4. I create a sequencer in XT and enter some notes for a MIDI track, connect a MIDI cable from the sequencer OUT to Jthalamus IN, and a MIDI cable from Jthalamus OUT to an instrument VSTi’s IN.
  5. I have Renoise “MIDI Input config (Master Keyboard)” set to MIDI Yoke NT: 1.
  6. I push play+record in Renoise and play in XT sequencer.

This configuration of mine doesn’t work, of course. But I don’t see where the problem is. How do you do it?

There’s a few problems with your setup there; rather than correcting them, I’ll give you my full working setup to get a step sequencer called Sonicbytes ERA talking to and synced with Renoise, and you can modify that for your needs:

  1. Load eXT as either a VSTi or a VST effect inside renoise, it doesn’t matter which.

  2. Inside eXT, load two instances of Jthalamus and one instance of ERA (or whatever other step sequencer, or eXT’s internal sequencer). Disconnect all cables which eXT has automatically connected to them.

  3. Connect Jthalamus 1’s MIDI OUT box to ERA’s MIDI IN box. Connect Jthalamus 1’s AUDIO OUT box to Master Out.

  4. Connect ERA’s MIDI OUT box to Jthalamus 2’s MIDI IN box. Connect Jthalamus 2’s AUDIO OUT box to Master Out.

  5. Connect ERA’s AUDIO OUT box to Master Out (even though none of these plugins create audio, eXT won’t activate them until they’re connected in this way).

  6. Open Jthalamus 1. On the “Input” tab, make sure the “MIDI Device” checkbox is checked, and that “VSTBUS” and “Receive MIDI from host” are unchecked. Choose the MIDI channel you want the step sequencer to receive MIDI from from the drop down box next to “MIDI Device”. (In my case, “MIDI Yoke NT: 1” which has a Remote 25 MIDI controller sending to it.) On the “Output” tab, make sure “Send MIDI to host” is checked and the other boxes aren’t.

  7. Open Jthalamus 2. On the “Input” tab, make sure “Receive MIDI from host” is checked and the other boxes aren’t. On the “Output” tab, make sure “MIDI Device” is checked and the other boxes aren’t. Choose the MIDI channel you want the step sequencer to send MIDI to from the drop down box next to “MIDI Device”. (In my case, “MIDI Yoke NT: 2”.)

  8. In Renoise, go to Configs -> MIDI and select the MIDI channel you selected in step 7 (i.e. in my case, “MIDI Yoke NT: 2”). This gets Renoise listening to the step sequencer as if it were some random external device, but the difference is that because it’s inside eXT, it’s synced with Renoise’s play commands.

(NOTE: Neither of the Jthalamus’s or the step sequencer are connected to either of eXT’s MIDI connections. It’s all done with external MIDI channels. Also, from memory, I couldn’t get this working with anything but MIDI Yoke channels; Renoise doesn’t seem to like giving any other channels up, so you end up with “That MIDI channel is currently in use” messages when you try and select them in Jthalamus…so you’ll probably need MIDI Yoke and MIDIOX. And it’s probably worth noting that I boot MIDIOX before I boot renoise, and it’s set up to map the Remote 25’s port to MIDI Yoke NT: 1.)

The result of this is that when you hit “Play” in renoise, the ERA step sequencer (or eXT’s internal sequencer or whatever you’re using) starts playing and sends it’s output to the currently selected renoise instrument, and is synced with renoise for recording if you’ve selected “Record” beforehand.

Hope that works for you, or you’re able to get the idea from that example and modify it to your needs…it’s remarkably stable, I expected lots of crashes, as is usually the case when you mess with MIDI plugins, but haven’t had any trouble with it yet. Jthalamus seems rock solid.

Anyway, if you’re still waiting for a piano roll, this workaround lets you have one (only one instrument at a time, mind you, but you can record and go on to the next, which is how most people seem to work anyway).

Thanks again rounser.

Although I didn’t get the above steps as a whole to work by replacing ERA with XT’s internal sequencer, your post was nevertheless helpful for my understanding of how Jthalamus works, etc.

If you ever were to succeed in using XT’s internal sequencer rather than ERA, please post your insights here.

(The only reason I want this to work is for the .mid-files import via XT. I have lots of .mid-files with hooks, riffs, arpeggios, Reason 3.0 tracks, etc. If I could import them into Renoise’s pattern editor, that would be just great.)

Replace ERA in the above instructions with the XT sequencer. Then, make sure you’ve gone to the XT sequencer’s Options menu and selected Sync -> External (this syncs eXT sequencer to renoise’s play and stop buttons). Then, once you’ve made a midi track with some notes on it, right click on the track’s box with the word “midi” in it and choose Output -> MIDI Out 1. Then press play in renoise with an occupied instrument slot selected. I got it working just then with those adjustments.

Allright! I finally got it to work now. However, in Renoise’s Config -> Midi menu, I have to set “In device A” to “MIDI Yoke NT: 1” and “In device B” to “MIDI Yoke NT: 2”. (I don’t know why it won’t work while listening to just one MIDI in port, as in your configuration above.)

Part of the problem for me is, I think, that energyXT is not very stable on my computer (P4/3.2 GHz/1024 with SB Audigy2 soundcard). So, for example, energyXT’s sequencer will not function properly – it stops autoscrolling to song position, it doesn’t trigger/sync (I’ll have to activate it by pressing C-3 on the computer keyboard while in play), I can’t access/edit the MIDI notes a second time, etcetera. Bad luck, I guess. I hope this problem might disappear with future versions of Renoise (I’m now running version 1.5.1. from Aug 24, 2004) and energyXT.

For anyone who is reading this thread: I hope you realize that the above steps provided by rounser and Ledger imply import and export of .MID-files into Renoise. This is a great work-around for anyone who is working with midi-files and would like to:

  1. Make arpeggios, basslines, etc in an external sequencer (e.g.Cubase, Logic, Reason, etc). Export to .mid-files. Import into Renoise’s pattern editor.

  2. Make arpeggios, basslines, etc in Renoise. Export to .mid-files. Import into Reason, Cubase, Logic.

:yeah:

When using XT as an instrument it is always best to uncheck the autosuspend box in VST instrument properties, this may help with the sync problems you are having. There is more detail in this quoted post from Pysj in this thread which may be useful to you. It also details methods how to stop XTe from autosuspending.

http://www.renoise.com/board/index.php?act…5eb14f3573f2406

Ledger, you rock!

:)

What can I say? :D :P