Experiencing Slowdown In Renoise

I have been experiencing slowdown in Renoise for a while now and I am trying to pin point what is wrong. I’ve been having the gui become very slow sometimes, scrolling instrument gets all stuttery, 'same for trying to draw an envelope in the automation editor.

At first I thought a script might be the reason, but now I think it is something else…

I’ve noticed that when I have Ohmboys Ohmicide open on the other monitor and draw automation of its parameters, the visual slowdown starts almost immediately. Same for the stuttery scrolling through the instrument list. When I close the plugin gui editor and then draw the same parameter or scroll the list, the glitches are gone and the visuals update without problems.

I just had a crash, incidentally saving while having the gui slowdown :( …and this is what the log says:

Was afraid I’d overwritten my song I’ve been working on for a few days with bad data, but miraculously it opens up fine, though my last half hour of automation tweaks weren’t saved, at least I can still work on it.

So it looks like it is an Ohmicide problem for now, but I’ll try automating more vst’s and have the gui’s open to see if I can replicate the slowdown.


windows vista / core 2 duo laptop / emu 202 / ohmicide 1.24.28161 [/i]

you’d better enable backup autosaving if you think that your song file is under risk

I’m not a fan of enabling this, have saved an extra back up though, also does autosaving overwrite or save a new version every time? It overwrites no? In that case it could be more dangerous as it could be crashing during playback/slowdown.

Why Vista? Commonly agreed to be about the worst Windows ever. Why not upgrade to Win7?

What don’t you like about it? You still save the song manually, which is safe and never touched. It then saves backups in a subfolder of the name of the song and saves the number of them you tell it to (2 as standard.) This will never affect your manual saves but might save you if something corrupts that while saving it. I have it set to have 2 different backups, save every 20mins (if there is change) and not to save while playing. Can not understand any reason not to enable it and to be honest really don’t understand why it’s not enabled by default.

Vista isn’t an issue here. I’ve never experienced problems with it and have tweaked it so it runs without annoyances, also I have a good discipline keeping my windows machines clean and tidy. Will eventually upgrade to a 64 bit machine when I get a new desktop and I’m sure it will be the newest Windows ;).

It is more psychological then anything else, but I don’t like using extra memory on the harddisk i [/i]and the idea of extra overhead, scheduling a task in the background while I often push the machine already running lots of plugins. Never really tried it though or felt it was necessary because I hardly experience these kind of fuck ups, this might be the first time in all my Renoising :) . Your set-up of 20 mins in between and not saving during playback is something I’ll consider. Maybe I really need a proper fuck up for the realization to hit me.

Have to admit I’m personally still using WinXP so can’t really argue if you find it’s working well enough for you. Keep on trying to get myself happy and familiar with Linux but various things do often pull me back to Windows at least for a while.

Core2Duo is a 64bit machine ;)

Definitely agree with the facepalm with the cost of hard drives these days! Unless you’re maybe on a small SSD in your laptop… But still I would want the safety I think

Hence telling it to not do it while playing, so it will only come into play once you hit the Stop button and the computer is doing much less. Even a setting of something like 120mins could turn out to be a lifesaver if, like me, you generally save over the old file most of the time rather than save many different versions as it progresses. Which, as you seem to think HDD MB are precious, it would seem likely you do :P

I’ve been noticing something else on the slow-down/glitch front:

Scrolling a messageboard on one monitor, while having Renoise play a song with the cpu in it @ averaging around 60% (no other vsti window open or anything) on the other monitor -> will shoot up the cpu usage in Renoise +20%, occasionally introducing glitches in the audio stream!

I don’t think this is supposed to happen. I am using directsound Emu 202 drivers for above example.

Switching to the Emu 202 asio drivers I get around 50% cpu in Renoise, and +15% when scrolling through a Mozilla screen.

Switching to Asio4all; 40% cpu for same looped section in a song, +9% while scrolling an internet site.

With scrolling I mean sliding the side bar with the mouse quickly up and down.

The difference in cpu can be there, because 'm using different latency settings for the driers, but it looks like the 202 drivers suck:

directsound emu = 12 msec
asio emu = 8 msec
asio4all = 11.6 msec

(all at 44100, no limit to stereo in/out enabled or dithering in the Audio preferences).

Anyone else with emu drivers or other external soundcards can confirm cpu shooting up in Renoise scrolling a site on another screen? Is this to be expected?

Are you talking about the USB version? In that case I can confirm this.

I get this too (well, I have only one screen, but the behavior is the same). What’s worse, the emu drivers cause a cpu spike every 15 seconds or so, which makes the cpu load for one processor core max out, thereby severely limiting my laptop’s processing power. Still, with directsound drivers at a high latency setting and/or a low cpu load, it is not unusable. So if you don’t mind the extra latency, you could consider increasing the buffer size. I use a buffer size of 40 ms when using directsound and that pretty much solves the problem as long as the cpu load doesn’t exceed about 70-80%. When I want to record live, I switch to ASIO, which allows for lower latencies (around 8 ms), but is less reliable.

I find it also helps a bit if I disable Aero Glass, run Renoise in fullscreen mode and disable wifi. (this is in windows 7 by the way)

yep usb version, shame to hear their drivers suck, will investigate if there’s an emu forum for bug reports or anything / check for driver updates.

Anyway, just had a similar crash again, trying to save a song while it was playing back:

I wouldn’t count on a quick solution. Anyway, this is the most helpful forum I found for issues with e-mu interfaces. There is a guy from e-mu who sometimes posts there, but e-mu are very slow with driver updates. I get the feeling that they just don’t bother.

Oh, and this is their site for beta drivers. Last update: october 2010, and that was before the latest drivers were released. Others and I have had reported the problems with cpu spikes long before that, and I’m not even sure they even tried to fix them.

Thanks for the info/link, shame to hear they have shitty support. Not 100% sure though, it is strictly the Emu’s fault. Ever since I updated Vista through windows update (after a year of not doing so), plus installing Buzz, which needed NET Framework 4 Client to run, this seems to have worsened / started.

You sure that is due to the Emu driver itself? If you get this when using DirectSound, ASIO and ASIO4All I would very much doubt that! It sounds more likely a DPC problem, which can be caused by any driver (and some other software) on your computer and affects and real-time process such as audio and video streaming. Network drivers seem to be one of the more
common causes and you say turning off your network device does improve matters some, which doesn’t surprise me.

Suggest you have a look into this little program:

Have to read the doc’s of the program/site what it means, but roughly every 20 seconds, sometimes 10, I get a spike around 1008 us, in between it averages under 200, mostly 25 us.

It says; ‘this machine should be able to handle real-time streaming of audio and/or video data without drop-out’. Is this a conclusion based on the analysing of dpc, or some global conclusion based on hardware specs?

DPC only I believe. Been quite a while since I looked into it much but unfortunately it can not really tell you where to look, the idea seems to be to run it and then check what difference you get by enabling/disabling different functions/services such as network/wireless to work out which might be causing problems. Most times I’ve found there is periodic drop-out or strange clicky/glitchy sound it has seemed to experience spikes (couldn’t give you values as was a long time ago I last used it) so thought it may be worth you trying it.

Just ran it on mine for the last five minutes or so and my absolute peak is 139uS so your peak of 1000+uS does seem quite high and must be just off the edge where they say it’s problematic. Maybe try running with your Renoise project and see if the spikes do seem to happen at the same time as your drop-out.

EDIT: Sorry Jonas, just realised I was replying to you and not Nism, who seems to get the CPU spikes/drop out. I doubt very much this will make any difference to your windows scrolling/slow down issue and was aiming at more at the CPU spikes mentioned be Nism. Hope you find it of some use anyway.

To see if it is the soundcard driver you should disable it and see if you still get similar spikes in reading. Usual way would be through the Device Manager but as you are talking about a USB soundcard I would of thought just not having it plugged in means its driver is not active. Afraid I couldn’t swear to that though, so may be worth plugging it in and disabling through Device Manager anyway…

I have definitely found network to be problem devices in the past. I discovered that my internal modem is on the same bus as my on-board audio and as I don’t think I’ll ever use it never installed the drivers and disabled (same with my webcam and bluetooth.) On my old desktop I had the on-board audio disabled in BIOS although it did develop a DPC problem later in life I never quite managed to track down…

DPC issues are definitely part of the problem, but I’m not convinced they can account for the spikes that occur every 15 seconds and last a couple of seconds. The main reason is that they only occur when the 0202 is connected. Also, while performance seems slightly better with wifi turned off (might be a placebo effect), these spikes remain. I’ve tried disabling all kinds of devices too, but nothing worked. I’m not 100% sure, but if it were a DPC issue unrelated to the emu device, wouldn’t these spikes also occur when the audio interface is disconnected? Realtime performance when using the internal soundcard is better (but the sound quality is crap). The real test would be to try a different audio interface, but I haven’t had the chance to try that yet.

Running Renoise along side now;

have only opened the song without playing it yet (using emu’s directsound drivers, 12 ms latency) and am already getting almost continuously spikes around 1000 us, sometimes dropping around 500 :( . Playing the song while analyzing strangely doesn’t increase the peaks at all it seems.

Switching to emu’s asio drivers gives me exactly the same values of almost continuous peaking at 1000 us, whether the song is playing or not.

Switching to asio4all almost cures the continuous spiking problem (no audio drop-outs though, song stays around 60% cpu in Renoise)
, laptop fan get quiet too, peaks die to around 25 to 100 us, with a 1000 us peak every 20 seconds like noticed before opening Renoise. Pulling out the Emu soundcards usb cable doesn’t kill the occasional spikes, although the 20 second interval looks changed at first. Changing to another usb port gives the same results.

Meh, something fishy is going on and I can’t put my finger on it yet, what’s causing this. I’ll disable internet after this post to see if it makes a difference.

Well from a combination of your posts it seems you may be right with Emu drivers being very poor.

Are you both using Vista/Win7? Quite a few companies still suffer from poor driver support later than XinXP…

Did wonder if it could possibly be USB drivers but seems slightly doubtful, although I guess it is possible you both have a computer which uses the same USB chipset and driver, but with switching to ASIO4All improve things so much I would suspect this is a red herring.

Mine generally runs flat about 80-100 and this has been with Renoise open using ASIO4All on internal Realtek HD audio. If I open a Youtube page I’ll get a brief spike. Not sure quite what I did (think I was only opening a mail in Hotmail) but noticed my ASIO4All symbol in Status Bar had gone red and had a massive DPC spike. Only a one off and can’t recreate it though. It’s these periodic ones you seem to be experiencing which are more the worry!

Closed Renoise and my DPC has dropped to 25-35.

Although the Firefox fast scrolling causing heavy CPU usage is something I’ve noticed in the past and just tested and definitely does occur here too!

Open Task Manager, do nothing to get a base, click on Firefox and scroll up and down this page as fast as I can for a fair few seconds.

Clear spike and this is on a 2.83GHz quad core (Xeon but same range as Core2 really.)

From another forum post but this looks like it might be useful to you for finding where the spikes are coming from.

It seems that my wifi card is the problem after all. Strange, because I thought I had ruled this out months ago. But anyway, thanks for your help!