Extreme external hardware midi lag when activating Virus TI Control plugin

Hi,

I have a Virus TI and a Roland MKS50 (midi hardware synth) which I want to sequence.

When I sequence the mks50 via midi, everything seems in sync.

When I then open up the Virus Control Plugin, the midi latency to the MKS50 goes way out of hand, the Virus stays on tick though.

I’ve tried all the standard stuff (i’m a seasoned midi user), other buffersizes, multiple midi ouputs cards, setting static buffers on and off but nothing works. Futhermore I have a brand new audient evo 4 card, and a computer that has enough cpu cylces and memory, so everything should work perfectly.`

When I test the same setup in Ableton, there are no problems at all. But when I work in Ableton, i can’t get any music out of my hands, it’s terrible man :slight_smile:

Why is it that loading the virus control plugin breaks my midi output? Is it a PDC problem?

I hope you can help me.

(PS I want to use the plugin, so I can use the usb outputs of the virus. When I connect the virus only over midi, I can only use the hardware outputs and I have only 2 inputs on my audient card, which I need for my MKS.)

1 Like

Sounds like you have a Virus.

This is a long shot… but…

Have you tried slaving everything to the Roland?

I don’t know what you mean, but I’m pretty sure it’s not possible, :slight_smile: thanks.

I’m not looking for a a workaround, I just want to launch the Virus Control vst, without breaking renoise midi.

Midi Clock Settings'

Is it not possible to setup your Roland device as the midi clock master; slaving Renoise and the Virus to its clock?

Just a thought,t…

other than that, sorry I couldn’t be of much help

1 Like

The mks50 is an old analog synth, it does nothing with midi clock, thanks.

Well, I fixed it :expressionless:

The sound I was using from the MKS50 had a rather slow attack, so I thought maybe that causes the delay. But while looking at that I saw the track delay was at -81 - Maybe it was a good idea at the time I set it, but it’s pretty stupid now. No wonder I couldn’t fix the delay with the latency setting, if the track delay is on -81 :slight_smile:

Sorry for bothering you, I’m very happy everything works now.

1 Like