[fixed] Midi import: Polyphonic notes placed in wrong column


(ffx) #1

Steps to reproduce:

  1. Record four chords in a DAW with midi export, using four voices each chord (in studio one for example).

  2. At the beginning of chord 1, make one note very short like 1/16th, an then copy the same note after the now shortened note to 3/16th position.

  3. Export the event to a midi file and drag that file to renoise.

Actual result:

The note on 3/16th position is placed in front of a totally different note, so stopping the wrong note.

Expected result:

The note should be placed on a column where a note-off already appeared or no note at all did play so far.


(taktik) #2

I think you are taking the “The Etiquette Of Submitting A Bug Report” a bit too serious. An example MIDI file really would make things a lot easier for everyone here and would not require any further explanation?


(ffx) #3

:slight_smile: ok.

Attachment 6642 not found.


(ffx) #4

Hi,

if I import a drum midi sequence from VPS Avenger, all notes will be mixed randomly, plus the last column seems to be empty? Would be nice to have an option / options-popup, e.g. “sort columns by note”, “sort columns by instrument”, checkboxes “create at cursor position”, “create new tracks”. Is the midi import made in LUA?


#5

Is the midi import made in LUA?

Internal C/C++ routine?


(ffx) #6

Internal C/C++ routine?

Oh ok, it looks kind of slow that’s why I thought it could be inline LUA code or so :stuck_out_tongue: I think super nice would be drag’n’drop: You drag the midi file onto a specific track and position, and exactly there it will be imported. I also see no reason why it needs to use multiple tracks, as long as one and the same instrument number was used. Instead it could use track columns first, and sort the notes, accordingly to type (drums vs. melodic)