FM8, Massive, Pro-53 and Reaktor crashing Renoise on Startup WIN10

I bought a new laptop which has Windows 10 on - I’m preparing to format it and get 7 on there unless anyone has any ideas about this…

These plugins crash renoise on startup, but work fine standalone. I have tried setting the running in sandboxes option, but it still does the same.

There is no info on NI site about Win 10 compatibily - in any detail. I guess I should try other daws thinking about it.

Anyone experienced / overcome this?

There are load of other plugins which crash but these are the ones i care about

Here’s the compatibility list for NI.

I don’t have my copy of Massive installed at the moment, but I do have FM8 installed and that’s working just fine here on Windows 10 (fully up to date), in both 32-bit and 64-bit versions of Renoise 3.1.0

What error message(s) do you see when they crash?

Is it an error dialog from Renoise itself (skinned like Renoise), or coming directly from Windows (looking like a standard Windows dialog)?

Can you send us your log file?


Also running a lot of NI stuff here, most of the ones you mentioned too, except Pro53 and never had a problem with them on Windows 10. I don’t think Windows 10 is the culprit but something else. What happens if you run Renoise as admin? Maybe the default account is restricted a lot, happens a lot if the VST folder resides inside the “Program Files” folder. Also for a test disable any Antivirus software. Heard of them causing crashes for plugins in some cases. If you want to move you NI plugins from one location to another, use the VST Tool they provide. It will update registry entries as well and not break any installations, in case you moved something by hand.

Imo keep 10 on it, probably just some initial authority tweaks needed? Can’t remember what changes are needed, have you tried changing the read only properties of the vst(i) / audio programs folders? (right mouse click the folder and toggle the checkbox) Also in the same window you can set the security settings, see what permissions you have, try the different permissions.

What could also be a thing is running the concerned apps as administrator; for example right mouse click the renoise icon, go to the compatibility tab and set ‘Run this program as administrator’, apply maybe do the same for the plugins and see if there are still crashes?

Last thing I remember is also allowing audio programs to run without my virus/firewall program possibly interfering, setting rules in the preferences.

hmm I tried turning off read only, and it looked like it worked then I realised I had `scan failed plugins’ unchecked

It hangs on the renoise loading screen when it scans all plugins eg - Loading Massive …

Also tried running as admin. And tried (as suggested elsewhere) to load the vsts in 32 bit version of program 1st. I think I’ll go for a reinstall, I appreciate all the help


Thanks for the help on this one I’ve managed to eventually get a new SSD drive and Win7 on the laptop (against the advice of HP!)

Shouldnt have any more problems