From Renoise To Live!

Hi all,

I know this might not be the ideal place to ask how to figure this one out but I’m thinking other people may come across the same problem.

I’m trying my hand at playing a Renoise song in Live!

I started out by rendering entire song lenghts of each group (bassdrums, melody, percussion, bass)
So I basically have 4 3 minute wav files I want to layer and play in Live. Sounds easy? think again!
I tried to import these into Live into 4 audio tracks, but for some inexplicable reason Live seems to think they are all of different lenghts and sets them to different tempos. The result is utter chaos, which is actually quite nice in an IDM sort of way but it won’t do for the live act I want to play ;)

Here are the things I have tried to do in Live to get a simple syncronized playback in the session window (but to no avail)

  • I set the song tempo to the same BPM as my original Renoise song
  • I set the bpm in “warp” to the right BPM for each wav file. it changed nothing
  • I disabled “warp”, it changed nothing
  • switched from swing (default) to “straight” (it made no difference)
  • changed quantize from “global” to “none” (it made no difference)
  • tried disabling just about everything that I could (no change)

Also, I noticed that the sound quality is pretty crap because of this real time warp function (but ALSO when disabled). It dosnt seem to bother DJ’s in night clubs but it sure hurts when you’re a producer :confused:

Also, the 4 waves are EXACTLY the same size (as rendered from Renoise). I can’t believe how complicated it is to just play 4 wave files at the same time in Live!

Any ideas?

hm, that is mighty strange. when you trigger the 4 wave-files in a renoise song at the same time, are they synched?
and do they all have the exact same lenght?
hm, sounds actually like it.

i can’t really help you, but i think i once heard, that live “cuts” out empty beginnings in audiofiles (non-destructively, the first marker is just set to the first detected “sound”), so perhaps that’s the problem? dunno. i got a question: if you just wanna play them in synch anyway, why don’t you just render the entire song and play that in live? that should work just fine.

you could also tell us more about the amount of “unsynchness”. are we talking milliseconds? or are whole parts missing? i mean wtf :confused:

well, sry. i’m not really into live.

Is it possible to manually set that marker to the beginning? I’ve never used Live, but if it’s any good I can’t imagine that is not possible?

Otherwise, try playing a very very faint sound with instant attack in each separate piece you’re rendering? (for bonus points, change the composition to accomplish that ^^)

They are exactly the same lenght in miliseconds and size in bytes (same amount of patterns rendered). I wanted to do several groups to have some fun tweaking them live … but it looks like that isnt as easy as it seemed. even my 2 bassdrum tracks are slightly out of sync :(
Also, once the “wrap” function is off I cant see any sample offset params.

gotta look further into this… I’ll post here if I find the solution, it might help others

Disable the autowarping of long samples in Lives “Record/Warp/Launch” preferences pane. Autowarping tries to find beats/tempos in long samples, which doesnt work very well when not using plain & stipid 4/4 base drum riffs…

Always set your own beat markers, ableton will make a complete mess of it if you let it do it automatically.

Zoom in, correct, and then right-click on the first beat and choose ‘warp from here: straight’, then set the tempo at that marker to whatever the track you exported was. Then have a quick skip around with the metronome on just to make sure it’s all in sync.

I usually put a marker at the start of each 32 bars or so just to be sure.

Aswell as the beat markers, there is also the trigger startpoint thing (its a small triangle pointing to the right) make sure this is snapped to the first beat also or everything will be off kilter (thats probably what your main problem is to be honest).

wows thats fixed it !

Actually, I followed taktik’s advice by disabling the auto warp thing from the the prefs. Then imported my wavs, and then turned the warp function ON for each wav file. I don’t know why but now it sees them correctly : 155bpm and everything is perfectly in sync, plus i can play arround with the warp feature :)