GPU drawing vst plugin question


#1

Hi just a quick question :slight_smile:

Windows 7 32 bit.

Certain VSTs plugins like the ones from Melda productions -> https://www.meldaproduction.com/plugins/effects.php use the GPU to accelerate drawing operations. I’ve found that with one of these plugins on screen with Renoise scrolling away in the background the frame rate update of the Renoise GUI drops considerably (it looks like 3-4 FPS). If I disable the GPU acceleration within the plugin(s), Renoise GUI frame rate is fine. Just wondering if anybody else has noticed this (or with other plugins)?


(Carbonthief) #2

I noticed this yesterday too with a Melda plugin. Renoise keeps playing the audio but visually is just frozen, changes frames every now and then.


(ffx) #3

this happens, if sandbox is enabled. if your plugins do not tend to crash, disable it and enjoy a huge performance boost.


#4

Ah, thanks Carbon, I’m not seeing things then :slight_smile:

@Jurek, no sandboxing is enabled :slight_smile:

I find disabling the GPU accel from the Melda plugin settings (making the CPU do the drawing) helps, but that isn’t the point is it?

So just another tiny little problem for TakTik. Ah, don’t worry in the future when more VSTs use the GPU and he gets about 50000 posts saying why the Renoise GUI frame rate drops to 1-2 FPS then he might, just might, take a little interest in the topic :slight_smile:


(ffx) #5

Oh, then it changed or I was wrong. I totally agree, constant framerate would be very useful :slight_smile:


(dblue) #6

Certain VSTs plugins like the ones from Melda productions (…)

There’s rather a lot to choose from there. Can you give a few specific examples?

I’ve already tried a few of them myself — flanger, ringmod, analyzer, and some other random ones — but I can’t manage to replicate any noticeable FPS drops here. (Windows 8 64-bit, running Renoise 3.0.1 32-bit for testing.)

They do all seem to be sharing the same base plugin technology, but who knows if certain ones are behaving slightly different from the others, so it would be great to know exactly which ones you’ve experienced problems with so far.

It would also be great to learn a bit more about your system in general.

Are you on a laptop or desktop machine?

Do you have an integrated Intel GPU on your motherboard, or a dedicated NVIDIA/ATI GPU, or both?

Single display? Multiple monitors? Any kind of virtual desktop stuff?

In some cases — especially on laptops with both integrated and dedicated GPUs (like my own) — Windows apps will use the integrated graphics by default, while games and other stuff can be configured to use the dedicated GPU through the GPU’s control panel. If you’re in a similar situation, you may need to explicitly tell your GPU that Renoise should use it. I’m still not sure exactly how that would affect the plugins, though, or how Melda even detects the correct GPU hardware to begin with.

Anyway… If you can mention a few more details — and post your “Log.txt” file from your Renoise preferences folder — maybe it will reveal some other clues.


(toblerpone) #7

Try updating your graphics drivers to the latest version, I do have this issue for some time on a vastly more powerful Winodws 7 x64 (very old driver I can’t update) and don’t on a 8.1 laptop.


#8

Sorry dblue, I should of said: ‘With Melda demo plugins in my case.’ (I was just wondering if anybody has run other VSTs that use very fancy graphic updates :slight_smile: )

Windows 7 32-bit

Core i5 3550 desktop

Nvidia GTX 750

Renoise 3.1b4 32-bit

(I’ve just installed the latest video driver gova, thanks for messing up my HD :smiley: )

Single monitor, no virtual desktop programs

Looks a bit hit and miss with systems then whether the Renoise GUI FPS drops or not.

So to just clarify then we have:

Carbonthief: Yes, frame rate drop with Melda plugins (not sure if Windows 10.)

Gova: Yes on Windows 7 x64, frame rate drop with Melda plugins. No with Windows 8.1 laptop.

Me: Yes Windows 7 32 bit, frame rate drop with Melda plugins.

DBlue: No FPS drop with Windows 8 64-bit with Melda plugins.

A big thank you to all who tried (and put up with my nonsense over the years) :slight_smile:


(toblerpone) #9

Melda demo are exactly the same as non-demo, and yes, as you see others have the same problem.

dblue: happens with all melda plugins, same kernel, gui etc.


(ffx) #10

Not on OSX. Everything nice with Melda (hw accelerated). Only Waves gui causes Renoise 32bit version GUI to stutter while controls movements. Not so 64bit. I guess its waves’ prob. Anyway I stay away from waves.


(Beatslaughter) #11

Might be related, i have the same problem with NI Replika in Renoise. Works just fine in Reaper on the same system. When they released it, it was buggy in a lot of hosts but meanwhile they pushed out a few updates and it works now, only Renoise is odd with it from my knowledge.

Edit: Vengeance Scope, the spectrum waterfall view provokes it as well for me.


#12

I was thinking a bit more about this…

On my NVidia control panel there is this option:

Attachment 6252 not found.

As you can see I’ve set it to off on the vertical sync (without Renoise loaded!) That seems to cure the frame rate drops/stuttering with Renoise and the Melda plugins. Beatslaughter and 68000 you would have to see if that helps you with NI Replika etc with your video setup.

The downside is now those plugins (or any DirectX/OpenGL applications) are probably not synced to the vertical trace of the monitor when they present their video buffer.


(toblerpone) #13

If you go into the melda plugin’s settings and set the fps to60 or lower, it’s improved a bit.


#14

Yup, missed that option gova :slight_smile: I’ve set the FPS in Melda to 60fps and with vertical sync on in the NVidia control panel and it’s now fine (on my machine). (Don’t know if speed of machine would also have an effect though.) If I set it higher (in Melda) than my monitors refresh (say 80FPS), then Renoise refresh stops and starts (but that’s probably correct.) Ultimately what I’m saying is if a OpenGL/DirectX plugin is giving Renoise a bit of grief (AND the plugin doesn’t give the option to frame limit) then try setting the vertical sync option to off and see if that improves the situation :slight_smile:


(Beatslaughter) #15

Tested around with this setting a bit and when i disable the FPS limiter in Renoise and disable VSYNC i can notice slight improvements in Scope, but it does not fix it, some views are still choppy. For Replika it does not make a difference at all.


#16

Beatslaughter: Sorry about that :frowning: (worth a try with the vertical sync thing though :slight_smile: ), possibly your problem is a bit more complicated depending on what they are doing in those plugins and Renoise.


(Beatslaughter) #17

The Replika issue has been fixed by NI with version 1.3.0, it runs fine now in Renoise.


(ffx) #18

This now happens very commonly on Renoise macOS in Sierra++. Would be nice if all those GUI performance issues were addressed by the Renoise team.