Help: Audio interface suddenly not detected by Linux

Hi

TLDR: scarlet 2i4 audio interface suddenly no longer being recognized by Linux Mint.

In depth:
I have a Focusrite Scarlet 2i4 Gen1 that was working fine on Linux Mint 19 this morning. But come this evening when I turned on the laptop again it’s no longer being seen by Mint’s sound devices. I didn’t update or change anything. It just disappeared from my available audio devices.

The thing is, I can still monitor incoming audio via the unit. And thus it’s still getting power via USB (with a little green light on the unit and all).

It’s also listed under the connected USB devices list via “$ lsusb”. But no matter what I try I can’t make it show up in my audio devices in the sound tab.

I’ve tried the usual things like switching out the USB cables and ports. Even tried it under a clean portable version of Mint 20.3 but that yields the same problem.

Unfortunately I don’t have access to another computer at the moment to try to connect the 2i4 to. To rule out the USB ports on my laptop. Though other USB devices work just fine, so the USB ports aren’t highly suspect.

Do you have any ideas on what I can try to get it work again?

Or do you have any ideas as to what might have failed on the unit that causes this behavior?

I’m not incredibly Linux savvy but I am willing to try things & learn.

Thank you for thinking along!

Try it via a live CD on usb key

1 Like

Thanks for the suggestion Omnix. I’m already on Linux and don’t have access to a window machine at the moment. I did try a different, clean install of Linux mint running from usb but the same problem persists.

The 2i4 interface was running fine under Linux Mint earlier, and had been for ages. So I’m thinking there might be a hardware failure somewhere in the audio interface. Which would suck.

Anyway, thanks again for thinking along!

1 Like

You can run a Live CD/USB thing in Linux, you just have to set your computer to boot from the USB stick. That’s usually done in BIOS: there should be a page where you can select where to boot from. I suggest you read up on it, and find out how to do so with your computer system and BIOS. Once you boot to the Live Linux OS of choice from the USB stick, you should be able to connect your audio interface and see if it works using some general audio applications, like a music player, your browser, etc.

1 Like

Arch Linux Distros have a good hardware detection…I think you can use it in Live to be sure that the hardware is faulty

1 Like

Thank you @T-ger and @rburgosnavas, I’m gonna give it a shot. Both your inputs are greatly appreciated.

If you scared about arch Linux there is Manjaro that is easy to use

1 Like

Sorry for the slow reply.

Thank you all for your help and suggestions, much appreciated!

I’ve tried Archlinux, Mint and Ubuntu but the problem persists. The unit powers on, is listed among the USB devices but fails to be recognized as an audio interface. So something broke in the unit.

I’ll try opening it up to see what I can see but I don’t have high hopes unless it’s obviously wrong.

So I suspect that after a little shy of 7 years of daily use it’s the end of the line for this Focusrite Scarlett 2i4 gen1.

Thanks again!

1 Like

For Linux I can also recommend the UMC Behringer

1 Like

This is a long shot, but you could try to clean the usb port on your scarlett, the contacts might have gotten dirty or even started to rust/corrode. If corroded you can maybe scrape the contacts with a nail file or something.

1 Like

I replied to lilith in my last post, but i meant to reply to eretsua.

1 Like