HELP: How To Control Renoise Instruments From Your DAW When Renoise Ru


(TIP) #1

Hi guys, I’m new to Renoise and i really need some help…

What i’m trying to achieve is to have Renoise running as a rewire slave within my DAW (Reaper) in a way that Redux works (like aVSTI),

The problem is that i can’t send Midi Out from Reaper to Renoise instruments , the only option on the**(MIDI Send to Rewire)** settings tab is: Master Keyboard output

6838 Rewire renoise (Master Keyboard).jpg

When i rewire Reason all the Instruments that i add in Reason, they are showing up immediately in Reaper rewire settings tab.

6839 Reason Rewire.jpg

I don’t understand why there is no option to port Midi to individual instruments in Renoise like in Reason.

I’ve tried several things with virtual midi cable but my midi clips from within Reaper not triggering anything…

I would really appreciate it if someone takes the time to explain me how to make it work.

Thanks!


(gentleclockdivider) #2

Renoise does NOt support multiple midi inputs ----->instruments

With that I mean ’ a separate midi bus ’ for every instrument.

I tried to do the same thing with bidule and hardware sequencers sending mutliple midichannels to renoise , it failed .

It would be great if this feature was added , then renoise could function as a vst /instrument host …container …controlled by external devices or other prog’s


(toblerpone) #3

You need to use a virtual midi port, I suggest loopmidi.
In reaper add renoise as rewire slave. By default it should automatically enable that track to recieve the left and right channel from the renoise Master track. Create a virtual midi port using loopmidi. Now make another track and use the Rout dialog to rout midi to this virtual midi port. Arm and monitor the tracks and use ASIO if you’re on windows.
In renoise chose an instrument in the instrument box and go to its MIDI tab, now set the input device of that instrument to your virtual midi port. You can also specify which channel and key range this instrument will listen to, that way you won’t have to use a lot of virtual midi ports. Make sure to give each instrument their own track and bind to it by choosing it in the Assigned track list.

gentle: I’m not certain what you are talking about, recording into the same track maybe? Recording into rewire slave renoise has it’s issues but they can be dealt with in an unhandy manner.


(gentleclockdivider) #4

You need to use a virtual midi port, I suggest loopmidi.
In reaper add renoise as rewire slave. By default it should automatically enable that track to recieve the left and right channel from the renoise Master track. Create a virtual midi port using loopmidi. Now make another track and use the Rout dialog to rout midi to this virtual midi port. Arm and monitor the tracks and use ASIO if you’re on windows.
In renoise chose an instrument in the instrument box and go to its MIDI tab, now set the input device of that instrument to your virtual midi port. You can also specify which channel and key range this instrument will listen to, that way you won’t have to use a lot of virtual midi ports. Make sure to give each instrument their own track and bind to it by choosing it in the Assigned track list.

gentle: I’m not certain what you are talking about, recording into the same track maybe? Recording into rewire slave renoise has it’s issues but they can be dealt with in an unhandy manner.

What I mean :create some instruments or vst’s . 1,2,3,4,…16

Control each instrument from a hardware sequencer over midi so each instrument or vst needs to have a separate midi input channel (1---->16).

This ain’t possible in renoise because renoise does not have multiple midi busses .


(danoise) #5

You need to use a virtual midi port, I suggest loopmidi.

Seconded. It’s a nifty piece of software.

This ain’t possible i renoise

Hm, has been ever since Renoise 2.7?
Head into MIDI tab > choose input and channel/key-range, even destination track


(TIP) #6

First of all, thank you all for trying to help, i really appreciate it!!!

The problem is that I’m doing everything the right way and instead of getting note messages, i’m getting pitch bend and control change messages, tried with both “loop midi” and “LoopBe” virtual midi drivers…

I’ll try to make a quick video and post it later and hopefully will be able to solve the problem, for now check this print screen to see what i’m talking about.

6841 Midi in.jpg


(gentleclockdivider) #7

Seconded. It’s a nifty piece of software.

Hm, has been ever since Renoise 2.7?
Head into MIDI tab > choose input and channel/key-range, even destination track

Fuck me sideways .

HOw come I have overlooked this ?


(TIP) #8

You need to use a virtual midi port, I suggest loopmidi.
In reaper add renoise as rewire slave. By default it should automatically enable that track to recieve the left and right channel from the renoise Master track. Create a virtual midi port using loopmidi. Now make another track and use the Rout dialog to rout midi to this virtual midi port. Arm and monitor the tracks and use ASIO if you’re on windows.
In renoise chose an instrument in the instrument box and go to its MIDI tab, now set the input device of that instrument to your virtual midi port. You can also specify which channel and key range this instrument will listen to, that way you won’t have to use a lot of virtual midi ports. Make sure to give each instrument their own track and bind to it by choosing it in the Assigned track list.

gentle: I’m not certain what you are talking about, recording into the same track maybe? Recording into rewire slave renoise has it’s issues but they can be dealt with in an unhandy manner.

Hey toblerpone, do you mind telling me what settings you have in Reaper preferences under midi tab.


(TIP) #9

So, here is a short video showing all the steps i did trying to make it work but unfortunately with no luck… Sorry for my horrible accent :blink:

Maybe toblerpone has the answer, please guys tell me what am I missing here…

https://www.youtube.com/watch?v=O4BOIVrG-T0&feature=youtu.be


(danoise) #10

Hm, Rewire or no Rewire, you *should* be able to send notes through a virtual MIDI port like that.

Makes me wonder if the LoopBe driver decided to shut itself down? It has built-in feedback detection, and while connecting these things it’s quite easy to accidentally trigger a feedback and (as a result) shut down the port.
One of the reasons I prefer loopMIDI over LoopBe is that loopMIDI offers a bit more control over this whole detection business.

instead of getting note messages, i’m getting pitch bend and control change messages

At least here you were getting _something._Another indication that the port was shut down?


(gentleclockdivider) #11

Short question , why is the loopback deivce needed ?

Since rewire boths carries audio and midi , given the example of reaper controlling each of Reason’s instrument on it’s own midi channel /audio bus .

Why does renoise require the loopback ?


(TIP) #12

Hm, Rewire or no Rewire, you *should* be able to send notes through a virtual MIDI port like that.

Makes me wonder if the LoopBe driver decided to shut itself down? It has built-in feedback detection, and while connecting these things it’s quite easy to accidentally trigger a feedback and (as a result) shut down the port.
One of the reasons I prefer loopMIDI over LoopBe is that loopMIDI offers a bit more control over this whole detection business.

At least here you were getting _something._Another indication that the port was shut down?

Thanks for your reply danoise, unfortunatelly I’m getting the same results with loopMIDI, i don’t know what is going on at this point, i also tried in another computer with a fresh copy of windows with no luck again…

Is anyone in the Renoise community able to make it work as it should, what about you danoise? Please guys, if you have a solution, i would really appreciated it if you could post it here.

Thanks!


(TIP) #13

Short question , why is the loopback deivce needed ?

Since rewire boths carries audio and midi , given the example of reaper controlling each of Reason’s instrument on it’s own midi channel /audio bus .

Why does renoise require the loopback ?

Heygentleclockdivider, as you can see in the first pic of my first post, Renoise unfortunately when is rewired as slave doesn’t have the option to receive MIDI for every individual instrument separately, but only an option to send master midi out form your Rewire Master (Reaper) in my case, so you have to use a virtual midi driver like loopMIDI to be able to send MIDI to individual Instruments…

The bad thing is that i can’t find the way to make it work…


(toblerpone) #14

Sorry, couldn’t reply. Under no normal circumstance should it change the content of your midi message, i’ll make a reaper and renoise project later this evening and post it.

EDIT:

https://www.dropbox.com/s/tf52mtz329hffom/reapernoise.xrns?dl=1

https://www.dropbox.com/s/lozid4cxngthb4i/reapernoise.rpp?dl=1

make a virtual midi port called 1 then open the .rpp, let it load fully then open the .xrns


(toblerpone) #15

Rendering offline generally turns off midi outs and ins in daws. So simply, when everything is done, let the entire song be recorded in renoise, then render offline.


(boonier) #16

The only way I can get midi sent from Reaper -> Renoise is by creating a standard midi track set to Renoise midi in port, and using another track containing a Rewire: Renoise device for the return audio. To hear the return audio in sync with the midi, I have to Record arm the return track in Reaper, thereby losing any kind of metering level.

This is not normal - something is very not right about the way this works. Midi though Rewire should not be using inter-application midi bus; it should be going through the Rewire bus system, and Midi and audio should occupy the same track. I may as well be using Soundflower and a IAC bus.

I don’t want to come across as harsh, but this problem doesn’t seem to be addressed in any of the workarounds :(and the lament of those yearning for a piano roll in Renoise would in someway be alleviated if this did work properly.


(can0) #17

I watched your video. I don’t use reaper, or LoopBe so I can’t really help you, but it looks like you have everything right on the Renoise side. What you want to do is possible in Renoise, I do it all the time, but with external gear. If you set up your Axiom as the input in Renoise, you should be able to play instruments in Renoise without loopbe or anything extra


(boonier) #18

FYI - I found this video to be most helpful when using Reaper and Renoise rewired together:

All latency woes gone. This was useful as well.http://wiki.cockos.com/wiki/index.php/ReWire Tshhh…manuals.

Still, fixing the midi in Rewire would be best :wink: hopefully in the upcoming bugfixes??


(TIP) #19

FYI - I found this video to be most helpful when using Reaper and Renoise rewired together:

https://www.youtube.com/watch?v=EtkFs3ezFz0&list=WL&index=27

All latency woes gone. This was useful as well.http://wiki.cockos.com/wiki/index.php/ReWire Tshhh…manuals.

Still, fixing the midi in Rewire would be best :wink: hopefully in the upcoming bugfixes??

As you said, Midi is the problem, the rewire audio works as it should…