Help with sample slicing / render slices to phrase

I just can’t get this to work right.


  1. Make a new song at 140bpm
  2. Load up factory included “SM101_brk_back II soul_102bpm”
    2.a ( optional, does it even do anything when slicing? set beat sync 128bpm percussion )
  3. Auto slice sample using transients ( I used 10%, tried others too )
  4. Render slices to phrase, render slice options: 8lpb, no quantize ( tried other settings too )
  5. Play phrase

The phrase plays really choppy compared to the waveform editor playback

Am I doing this wrong?

Thank you

Edit: If I change song bpm to 102 it sounds ok. Still not “perfect” as one might expect. So I guess I need to destructively apply beatsync settings to the original SM101_brk_back II soul_102bpm. Do I have to render a pattern to a new sample in the pattern editor or is there an option I’m missing? I tried using rubberbandaid but cannot figure the settings to make it sync like beat sync. Thank you

Edit: I found out of I “Apply Current Beatsync Values to transpose and fine tune” of the original sample to the sample slices, the rendered phrase will play perfect, altho pitch has changed. So for reference, it appears just not possible to render slices to a phrase and have it play with the original pitch.

And it appears the only way to destructively apply beatsync timestretch to the sample is making a pattern of the sample and rendering the pattern. Unfortunately the gain is much lower in the rendered pattern of the original sample so noise is introduced.

EDIT: Every once in a while the “render slices to phrase” bugs out and doesn’t make a phrase the same length as the beat sync line length value, so you must fix the phrase manually

It definitely doesn’t make sense you can’t:

  1. beatsync a loop
  2. slice a loop
  3. play the slices as they are beat synced, easily as clicking 3 buttons

all the tools are there, its just not put together right?

EDIT: It is broken as of 3.4.2
There is broken workflow of beatsync’d loops, rendering slices to phrase. Currently, If you slice a beatsynced loop, “apply beatsync values to transpose and fine tune”, not only are the transpose and fine tune settings not applied to the slices, it will not make a phrase of the correct size if its not a size 64line loop. If you put in the transpose/fine tune values for the slices, and change the length/expand the phrase, it will work.

If you apply beatsync to the sample, then press the little T icon next to it, this will calculate the corresponding transpose & fine tune settings for the particular sound, now autoslice it and all slices will have the correct transpose & finetune settings for the bpm you have used beatsync in. If you don’t want the sound to change pitch, you can try & use one of the timestretch options instead of ‘repitch’;
For example when using this on breakbeats, the percussion option might sound better then the texture option.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.