Hexagonal keyboard does not work.


As I use Redux in Bitwig (LInux Mint 17, KDE) the computer keyboard for playing notes some times does not work. As ‘z’ is pressed the hexagonal z blinks accordingly but the view meter at the top right does not show any audio activity. There is a sample loaded and the octave is set right. I reported a same problem some time ago when using Ardour. Since then I haven’t used Redux but now I’m getting back to it, in Bitwig this time, and find the same problem. The problem was possiblytraced to Ardour not handling some calls in the proper manner I think.

Redux loaded stand-alone using the carla host (1), and loading the same Redux instrument, does not have this problem at all. The ‘z’ is pressed, the /z/ hexagon blinks, the VU meter shwos activity, and there’s audio output. Every time it is tried.

The hexagonal z key blinks but Redux is not ackowledging it since it does not provide any audio output.

(1) carla-single vst /usr/lib/lxvst/Redux/renoise_redux.so

7231 reduxHexKey.jpg

7232 reduxHexKey1.png

the computer keyboard for playing notes some times does not work.

This was the topic about Ardour, right?


Since you’re experiencing that it works “most of the time”, I guess it’s not the exact same error though…

Are you sure it’s not simply because you found yourself in the phrase editor?

When pressing keys there, they play the sample or keyzone (which can contain blank spots)


(I thought of doing a simple reply but then I got carried away and actually started doing some tests as I was writing this.)

It’s not the phrase editor. The screen shot snippet shows the bottom of the keymap editor.

Yes, that topic is the right one. I went back to Ardour with what was found, and then got not much from them. Now that the same is also found in Bitwig makes it not really tempting to pursue the Ardour road.

Well, I can use a compact Launchkey Mini to trigger notes, so there’s a workaround.

I tried it another time just now. Started Bitwig, load Redux as instument, load a drum loop, slice to phrase (non destructive). Works well. I mean, the hexagonal keyboard. In the phrase editor pressing for instance x, d, c plays the corresponding sliced samples.

And then, I save this very basic project, close Bitwig, restart Bitwig, reload project, open Redux GUI, go into editor mode (waveform is shown) and… now the hexagonal keys do not work and show the exact behaviour described above. Keys blinking to gray, no Redux VU activity. This would be the troubleshooting path.

Note: clicking with the mouse on the hexagonal keys also do not make any sounds.

It worked the first time upon creation of the project. When saving the project and reloading, not so.

Actually it is deeper than that. Even the existing phrase cannot be played. The play button at the bottom right is pressed and stays pressed but the phrase editor is not moving. Pressing the stop button next to it does nothing as the play button stays pressed.

I got back to Bitwig, load an audio loop and play it, it plays as usual: no, it’s not Bitwig that went under.

I now connect the Launchpad Mini.

I press the Redux stop button, and it responds. I press the hexagonal keys: they now respond, VU meter activity, sound produced.

I unplug the MIDI keyboard.

The hexagonal keys go back to not functionning.

I reconnect the MIDI keyboard.

The hexagonal keys still do not work. I press only one single MIDI key. Now the hexagonal keys work, phrase editor play/stop buttons also.

I have found the exact workaround then: connecting a MIDI keyboard, pressing one key, and putting the MIDI keyboard away, still connected.

I don’t know if this offers any insight on perhaps a condition in which Redux would wait for a MIDI event to happen.


It sounds like the MIDI message is waking up Redux.

Makes me wonder, is it possible to “auto-suspend” plugins like in Renoise? That would explain it.

Of course, going to give this a try here as well…

I did not read the topic at all, but yes, did you try disabling auto-suspend in bitwig’s instrument options (context menu on plugin)?

Seen similar problems with other plugins in bitwig, for example too late start…

Is it possible to disable/control ‘auto suspend’ in Ableton when plugin windows are not showing? If it isn’t, I then assume that Redux with a longer phrase with gaps of complete audio silence in the phrase for more than say 1-2 seconds with the Redux window not open stops playing the triggered phrase?

I was not aware of the instrument properties in Bitwig, thanks for mentionning it. I tried to replicate the problem but it works everytime, for now, using a new Bitwig session since I deleted the original test session I used above. As I use Redux I will see perhaps more of the environment that leads to this. - thanks.