How do I process external gear with Renoise fx and no echo?

Hey there!

I’ve been using my record player through my 2i2 audio interface for the last 5 years or so and processing it live through a Renoise FX chain with EQ and an amp vst. Anyway, it wasn’t until recently that I noticed there was an echo when using record mode, monitoring the output, and telling it to route to track 1 where I have my effects. Is there a way to only have the wet output signal so I don’t have the dry echoing in the background? Or is there maybe a better way to go about this? Thanks!

Maybe try using the Line-In DSP effect on the track where you have the effects and set the Line-In before the effects so you can hear how it sounds through the effects chain and turn off audio monitoring when you are using the sample recorder? That’s what I could think of without having Renoise open right now.

1 Like

Sweet, I think that sorta helped! But I also noticed I had the monitor knob halfway on my 2i2 interface. Turning it 100% wet cured the issue and now there’s no echo hahaha.