How to fix latency with qwerty and midi keyboard

Hey all,

I have latency even with using a qwerty keyboard. I have Renoise 3.4.2 on a reasonably capable laptop (i5 gaming laptop). The cpu level doesn’t go silly even with lots of plugins etc (less than 50% I guess).

I have tweaked a few settings from the prefs menu but I still get massive latency when just pressing a key to play a sample (it probably is a lag of half a second). There is also the same latency over midi.

I get the latency thing with viewing the screen with your eyes as the cursor follows the pattern… possibly to do with delay, effects etc. but not just hitting notes.

I’ve tried searching and trying different things, any tips to sort this out please? :slight_smile:

What audio drivers do you use, try asio drivers, also what are the buffer settings in the audio settings in the preferences? Try lowering the buffer and see what value works the best without glitching the output.

I assume you are on windows. So go to audio preferences and select ASIO as a driver. If you can’t select ASIO as a driver, download ASIO4ALL.

1 Like

Or just use WASAPI, it’s built in to Windows and gives good enough latency.


Getting an RME Babyface external audio interface (or one of their internal ones) would give you extremely low latencies beyond comparison. And you also get a pretty unique loopback function that lets you record/sample system-wide sounds. Their ASIO also lets you run ASIO in multiple apps simultaneously. I previously bought a HDSPe AIO internal interface but ran into a slight nuiscance called (you may have heard of it) coil whine, which picked up some circuit sounds from my GÖU. So thst’s why I’d personally (whenever I find the budget to) purchase a Babyface Pro. They’re
not cheap, though. (But you do get the best possible quality device money can buy.)