How to have sequencer follow playback when Pattern Follow = OFF ?

I know the subject sounds weird, since the whole point of having Pattern Follow ON is that the sequencer will follow the playback, but here’s what I’m wondering…

Is there a way to have the sequencer, during playback, jump forward to each pattern as it gets played, without having to enable Pattern Follow?

that is to say:

  • I don’t want to see the scrolling playback (it kinda gives me a headache, tbh!)

  • but I do want the currently-visible-pattern to update to the currently-playing pattern every a new pattern is reached during playback.

I only turn on Pattern Follow when I’m recording, since that’s literally the only way to do recording. But when I’m editing / playing back my music, I always have pattern follow off. It just looks better to me, and more to the point, the animated scrolling bugs out my eyes and I honestly can’t meaningfully read the text if it’s moving.

But during playback, with pattern follow off, the cursor will move down to subsequent patterns but I’ll still be looking at the first one, which means I have to manually page down / or manually jump through sequences with command-arrow-down to “manually follow” the progress of the playback. Is there any way to make it so it just “jumps” (display wise, e.g. what is shown on the screen) to the next pattern (once reached during playback)? This way I don’t have to manually hit keys to follow the playback, but I also don’t have to see the constant scrolling movement that I prefer not to see.

hope that makes sense! let me know if there’s some way to do this, thanks!

Under global preferences:

Turning this off should do it?

“Separate edit & play positions (with pattern follow disabled)”

7889 Pattern Follow.PNG

What If you change playposition color same as background color, to make it less distracting?

That’s it, precisely! Thanks!

It’s funny, because I had seen this option in preferences before, but didn’t understand what it meant… and now it turns out it means specifically a thing that I needed, ha!

Cheers, -M

Under global preferences:

Turning this off should do it?

“Separate edit & play positions (with pattern follow disabled)”

attachicon.gifPattern Follow.PNG