How To Install Renoise On Ubuntu 8.10 ?

I recently began using linux…

please help )

Hello springbass,

is there any particular step described in the Installation Guide that doesn’t work for you?

General Installation

A more detailed description of the installation procedure can be found here:

Setting up Renoise in Linux

But what about MORE detailed description how to install renoise in linux??
These tutorials didn’t help me much. Really. Renoise is the first application I’m attempting to install under linux environment (exept adobe flash player).
Can anyone help me out considering the fact I’m complete dumb when it comes to command lines and linux stuff…

Where exactly are you getting stuck? If you go the Applications menu in the upper left corner of your screen, then choose Accessories then Terminal, it should give you a command shell. From there you can follow the instructions on that first page.

It’s just the file system which is a bit confusing. Hmm…
Ok. I’ll just start from the beginning. I’ll even download the archive again.

So this is what I did.
Downloaded the package to my desktop. So the tutorial is about doing these procedures in home directory. I get there from ‘Places’->‘Home Folder’…copy-pasted the tar.gz file there.
Now the terminal.
Ok. Uncompressing went fine.
But from there It gone too abstract again…

Eeem?? Ah? :blink: :o :huh:

I would ignore the sudo part for now and just try running it directly as ./renoise.

Also, have a look at this thread to get some basics down for the command line.

After uncompressing and changing the directory the ‘./renoise’ did nothing.
But I tried the sudo thing too… Seems like it worked as it says the installation succeeded, but I still can’t run Renoise. :S

‘Could not launch menu item
Failed to execute childprocess “Renoise”
(No such file or directory)’

Same result as my last try… But now I’m quite sure I did exactly as the instruction said.

What happens if you type renoise in terminal?

eeter@ubuntu:~$ renoise
bash: /usr/local/bin/renoise: No such file or directory


But could this produce any fuckery, that I have installed the 64-bit Ubuntu?

No idea. Maybe you don’t have 32bit support libs installed or something. Although the error message is suspicious. It says file not found while knowing it should be in /usr/local/bin/renoise

I checked if that directory exists. Yes it does, containing 2 files: renoise-2.0.0 and a linking file… Both files don’t seem to do anything when I try to execute them.

Maybe it would be better if I try to install 32-bit version instead of 64-bit?
And what can you say about Ubuntu Studio? Do you recommend it or not?

Yes, definitely - until we published a 64bit Linux version of Renoise.

Ubuntu Studio is the easiest way to have a fully working Linux environment with preinstalled RealTime Kernel. HOwever, please use 8.04, as version 8.10 has no RealTime as of now.

Definitely go with the 32 bit version. It’s a lot easier to get it working.

Also, you have to type “./renoise” not just “renoise”. The dot and the slash are important.

Ok. Thanks guys. I’ll try it tonight;)

Ok. Now I’ve got Renoise running on Ubuntu Studio 8.04
But can you tell me why it recognizes only one cpu?

Make sure in the audio preferences that you have multiple cpus enabled.

You mean Renoise Preferences or other audio preferences?

Renoise preferences.