How to load a tool ?

Hello,

This must just be me. I navigatd all Renosie 3.0 menus and did not find any option to laod the Live Dive tool that I downloaded. Live Dive documentation says drag the tool on top of the Renosie app. That’s a no go. I’m using Linux and although I could I guess start a graphical file manager (which I never use) to navigate at the downloaded file and then drag it into Renoise, I am not doing that. So how to make available a tool in Renosie 3.,0 ?

Thanks.

Dragging the tool onto Renoise just installs it. To actually use a tool, well that varies from tool to tool. Some show up in context menus, some are just toggled in the tools menu. In the case of Live Dive, simply go to Tools>Live Dive>~Live Dive.

Let’s say there’s no drag n’ drop. How would a downloaded tool be loaded from within Renoise ?

If you just double click/ run the downloaded tool it should install.

OK, I got the Dolphin file manager running, which I never ever use. Selected the Live Dive icon and dropped it over the Renosie window. Tool succesfully installed. I guess if there’s no other way to go, then that"s it. Although it’d be nice to have a File -> Load -> Tool or something like that.

Cheers.

Frankly, i expected this option to be the diskbrowser -> click the [Other] tab and doubleclick the .xrnx, but clicking [.] is required to get the tools visible and doubleclicking one Renoise interprets a script-file as a sample.
Dragging and dropping a tool on an open Renoise window or double-clicking the tool (or right-click and then “open”) should actually install it, but if that does not work I guess installing from inside Renoise should be addressed as well.

I don’t use any file browsers or desktop environments on Linux, so dragging and dropping or double clicking on an icon are impossible for me. So what I’ve wound up doing is the following:

1 - Download the tool (which should be a zip file named something like “foo.xrnx”).

2 - To prepare for step 3, make a note of the contents of the “” tag in the “manifest.xml” file inside the zip file you downloaded. You should be able to get the contents of the “” tage with the following command, substituting “foo.xrnx” with the name of the zip file you downloaded: unzip -p foo.xrnx manifest.xml | grep ‘’ | awk -F’[<|>]’ ‘/Id/{print $3}’

3 - Unzip the file you downloaded to $RENOISE_INSTALL_PATH/share/renoise-$VERSION/Scripts/Tools/$ID.xrnx, where $RENOISE_INSTALL_PATH is the directory you installed renoise to, $VERSION is the version of Renoise you have installed, and $ID.xrnx is the contents of the “” field inside the “manifest.xml” file with “.xrnx” appended to the end.

4 - Restart Renoise.

For example, here’s how I installed the Renoise CDP Tool.

1 - Download “com.afta8_.CdpInterface_V0.62.xrnx”
2 - unzip -p com.afta8_.CdpInterface_V0.62.xrnx manifest.xml | grep ‘’ | awk -F’[<|>]’ ‘/Id/{print $3}’
3 - unzip com.afta8_.CdpInterface_V0.62.xrnx -d /usr/local/apps/renoise/share/renoise-3.1.0/Scripts/Tools/com.afta8.CdpInterface.xrnx
4 - Restart Renoise.

If anyone knows of a better way, I’d be interested in learning about it.

I hope at some point Renoise makes it easier to install tools from within Renoise itself, so that we don’t have to rely on external file managers or desktop environments.

Just a quick thought, but would it not be possible to write a lua script/tool that does steps 2-3? I’m not sure if you could replace step 4 with the ‘Reload all tools’ option on the tools menu afterwards.

BTW welcome to the forums. There is a nice little tune in the downloads section that matches your user ID perfectly -> http://forum.renoise.com/index.php/files/file/306-little-fugue-in-g-minor-bwv-578/ :smiley:

Ah, dblue seems to have come up with a better way :slight_smile:

If anyone knows of a better way, I’d be interested in learning about it.

Have you tried simply loading Renoise from the command line and passing in the tool .xrnx file as the first argument?

eg:

renoise com.blah.KickAssTool.xrnx

dblue: Thanks! That was on my list of things to try. Should have tried it before posting. Works great. … live and learn. :slight_smile:

Also, it looks like renoise itself installs the tools in to ~/.renoise/V$VERSION/Scripts/Tools rather than in to $RENOISE_INSTALL_PATH/share/renoise-$VERSION/Scripts/Tools/$ID.xrnx as I mentioned in my original post. They seem to work fine installed in either location.