How to set lines-per-phrase when rendering slices to phrase

Hello,
Please see video:

The video shows me adding 2 different audio files, one after the other to the sampler.
The first audio file is short, the 2nd audio file is much longer.
Notice the first (shorter audio) render results in a phrase of length of 256 lines.
The 2nd render (longer audio) results in a phrase of length 32 lines.
Which is the opposite of what I would expect, that is the longer audio would get the greater resolution, not vice versa.

Any idea why this is?
Any way to configure the number of lines in the resulting phrase?
Lines per beat under Render slice options seems to have an inconsistent effect.
Thanks

Brief followup.
Just slice-rendered an even shorter audio file and the phrase came out to 512 lines.
As I’m trying audio files with different lengths and placing varying number of slice markers, I can’t pinpoint a rhyme or reason to how the line resolution is decided.
Seems random

Can anyone offer any light?

Also see → Render Slices to Phrase Pattern Length Half the Number of Expected Beats - #2 by 4tey

What can we say/do?