How to set track numbers, samples, etc. to manual (and a weird thing)

Hi everyone

Proud tracker through 25 years here. I’m really impressed with Renoise but, as a puritan for total control, I would like to know if there’s any way to disable the autonumbering when adding patterns? It annoys me to no end, that everything skips, moves and is renumbered when I try to do things. I feel like I’m losing my overview. This also goes for adding samples and instruments.

And for a strange thing… I’ve loaded an older XM file, but for whatever reason, it loops the first pattern in the song indefinitely and refuses to move on.

Are you talking about the ‘keep sequence sorted’ option(?) https://tutorials.renoise.com/wiki/Pattern_Sequencer#Auto-Sorting_Patterns

Maybe if you provide a link to the XM file in question, might be able to tell why Renoise is repeating the first pattern. Also check https://tutorials.renoise.com/wiki/Pattern_Sequencer#Looping_Patterns

Yes! That worked :slight_smile:

I also found out that some kind of loop had been set in the small rectangle next to position 0 for some reason.

Thanks :slight_smile: