How to use Piz Midi plugins under OSX?

Hi,

I would like to use these midi vst plugins:http://www.thepiz.org/plugins/?p=pizmidi (free)

For example the midi swing.

How to setup that a sample track starts to shuffle?

Thx

I’ve heavily used these plugins in EnergyXT, but Renoise is reading some as VSTFXs and some as VSTi’s. The majority are enumerated as VST FX and cant load properly. Renoise asks me to rescan the VST folder so they’re properly cached(as intruments not FX), but there is no result. Currently I cant figure out how to route signal to them in Renoise. The plugin would only shuffle triggered note timing, and not the internal clock of a renoise track. One could in theory route track1 with note data to track 2 with pizswing effect to track 3 with sample. But most of the plugins arent registering as instruments, so can’t load:(

Still have nno clue how to use it :frowning:

Here is some option to switch those plugins to instrument mode:

http://www.thepiz.org/plugins/?p=pizmidi.ini

I checked on that, and by default it should force to instrument. I even adjusted it to be renoise specific with host=renoise. Still the plugs don’t show up in the instruments list. Renoise even recognizes that they “should” be in the instrument list. Funny thing is that the piz plugins in the instrument list load, but then a pop-up says they should be cached as effects. They don’t open with a “MIDI Routing” tab. I’m confused too.

Renoise explicitly says that MIDI generators are supported. Most of the piz plugs don’t generate any data, but rather affect or modulate. The choice of word “generator” sort of implies that MIDI instruments that only modulate data may not be supported. That being said, I did get WOK Ratchit to work- it only effects data.

I got some of the piz ones to work, regardless of what any popup or midi routing tab says.

Open a new song

Open midiswing on instrument 00

Open the sample or vsti you want to swing on inst 01

Route midiswing to instrument 01 (forgot to write this step on op)

Play or program the notes on a track going to instrument 00.

example: c-400, c-400,g-4 00,etc.

TIP: program 16, 16th notes of c-4 and play with the midiswing sliders to hear the timing offset. works here. sometimes notes get choked or cutoff from timing differences.

This is perhaps a piz problem? The WOK stuff seems ok. Plugin-host reporting issues? This is beyond my skill-set.

This fix from dblue prolly works?

  • Make aPlugin FX Aliasinstrument for the VST FX plugin you want to control.
  • Route your MIDI generator plugin to the alias instrument.
  • Profit.

So first add the piz vst effect to a track, select its alias in the instrument editor, route another midi vsti to it. Mm, trying it right now, the alias doesn’t have a midi destination field?

EDIT: I got some of the piz ones to work, regardless of what any popup or midi routing tab says.

Open a new song

Open midiswing on instrument 00

Open the sample or vsti you want to swing on inst 01

Play or program the notes with the instrument going to 00.

example: c-400, c-400,g-4 00,etc.

TIP: program 16, 16th notes of c-4 and play with the midiswing sliders to hear the timing offset. works here. sometimes notes get choked or cutoff from timing differences.

Are you on Mac? I guess on Windows… I only can open midiswing as fx, then there a VSTfx instrument alias appears. I tried your steps with that alias, but nothing happens on midi input.

This fix from dblue prolly works?

So first add the piz vst effect to a track, select its alias in the instrument editor, route another midi vsti to it. Mm, trying it right now, the alias doesn’t have a midi destination field?

I guess this only works for midi fx that itself alters the audio. But not for midi only fx…

Or not?

I am on windows. However I failed to mention that I load all vsts from the “vsti from menu” tool. Midiswing doesn’t appear in my instrument list either, but I’m capable of loading it in the instrument box through the tool.

Note loading behavior below.

Well, now it is not showing up in the vst from menu list either. And my number of vsti s went from 39 to 36. Weird.

Okay, and even weirder…Once I double click on a piz effect in the lower left effect browser I get the message that

“the plugin was cached as an effect, but it appears to be an instrument. Please rescan…”

Once that happens(without rescan), then the plugin is added to the instrument list on the standard plugin page and can be loaded from there…(but not through tool loading)

If I restart renoise it is available from the default plugin page, or through the vsti from menu tool.

If I restart my computer, all of the recently instrumentized piz plugins are reverted to “effects”.

Try clearing/deleting the VST cache files. You’ll find them in Renoise’s preference folder (Renoise -> Menu -> Help -> “Show Preferences Folder…”).
Will look into this. They should by default (also in the cache) be instruments.

Try clearing/deleting the VST cache files. You’ll find them in Renoise’s preference folder (Renoise -> Menu -> Help -> “Show Preferences Folder…”).
Will look into this. They should by default (also in the cache) be instruments.

That worked perfectly. Thanks!

There are so many helpful tools by pizmidi, but it seems that it doesn’t work on Renoise 3.1 OSX, since other it’s a midi FX and not a Midi generator, or something still doesn’t work as it should.

Would be very nice, if you could use such stuff like pizmidi, too!

http://www.thepiz.org/plugins/?p=pizmidi

Have a look on that page.

Hi,

sorry I still don’t get how to setup right… This is what I do:

  1. I put pizmidi midiPolyphony VST FX on track 1.

  2. I open VSTiFX aliasmidiPolyphony on instrument 1

  3. I put a VSTi on instrument 2 (the one that should be controlled)

  4. I set midi output on instrument 1 to “IAC-driver” / osx midi loopback.

  5. I set midi input on instrument 2 to the sameIAC-driver.

I can hear it playing, but no midi fx processing.

Where is the mistake I make?

Should the midiPiz stuff appear as instrument? I already rescanned a lot of times.

I also deleted pizmidi entries from cachedVST.db and rescanned. They still appear as fx, although the plugin config file is set to “force inst”. I use a subdir “_midi” inside VST dir. subdir, or not, makes no difference. config in both.

There does also no field for “routing” appear, under the alias VSTi…

Tested those plugins with ableton: There they seem to appear as instruments!

EDIT: Yepp, there it worx

Also moved pizmidi.ini now to ~/Library/pizmidi/ :blush: Filemon did show, it accesses the config from there.

Sadly still doesn’t work. Only in ableton it will be detected as instrument.

Delete the cachedvsts files in the renoise folder. I’m not sure of its exact location.

I removed the entries. Doesn’t help. You are on Windows, right? Does it work on anybodies OSX machine?