Hypertreading On P4's

I was very pusseled some time ago when someone on this forum
reported a problem with a rather hefty P4 cpu and to little prosessingpower.

And I could not figure out the reason, then it hit me like a ton of bricks…
When you get a cpu that supports hypertreading there are somethings that
must not be left out in the consideration. It is not just to install windows on
a P4 with HT, you have to set your bios right the first time.

In bios, If you choose the hypertreading off option on install. You get a system that does NOT hypertread when installed.

However, you are to sett your cpu managment to background tasks for best
usage of a musicprogram… this can generate a conflict…

If you want to enable Hypertreading, you cannot, and i stress this VERY CLEARLY
you cannot choose to have the system fix the task. Because it can turn on
the hypertreading by a patch. This is big problems!!!
Also, if you go to bios and enable HT and restart the computer, you now have
major problems calculating correctly, when running more than one program.

You must choose to reinstall the OS , windows again! With the HT set for
enabled.(in bios)
Then the setting in “my computer” set for backgroundtasks will be a good choice.

I think that users of P4’s with HT will have a problem with renoise if HT is set
wrong. And windows wrongly installed acordingly.

Or, there could be a hithertoo unknown bug in the cache routine managment
in renoise when running the newest p4’s …on some motherboards…or install
options.

:guitar:

This problem was mentioned in a norwegian hardwaresite recently.
And I think it is worh checking this if you experience computation issues
or program stability problems on you new P4 with HT

nfryspys

first off, i’m not really sure if i was able to understand what you actually wanted to say with your post.
but i think you essentially wanted to point out, that you have to install winxp/2k with the hyperthreading option enabled in bios in order to get a hyperthreading capable operating system.

that’s absolutely correct, but in fact, hyperthreading does nothing but hinder performance and create unpleasant issues, like VSTi crashes or even renoise crashes.

renoise tries to circumvent this behaviour by deactivating one of the two virtual CPUs (you can check that in your taskmanager when rightclicking on the renoise.exe task) by default, but that doesn’t solve the issues thoroughly. i still have to disable HT from within the BIOS if i want to work with synths like Novation V-Station without being flawed by malfunctions and suchlike.

so even if HT would not cause any bugs and issues with renoise, it would be in no way benefical because of the fact that the software only addresses one of the two virtual CPUs “out-of-the-box”.

so solely for using renoise, it doesn’t matter at all if the OS was installed multiprocessing capable or not.
i can only recommend to deactivate HT from within the BIOS, to prevent unpleasant behaviour with RNS.
besides that, i don’t know of a single VST / VSTi which supports HyperThreading or multiprocessor environments. so there’d be no performance gain anyway.

Might be true in you use Renoise only, but of course there are apps that take advantage of HT. For example I use Ulead Mediastudio for video editing, which supports HT, and I don’t want to disable HT altogether if I don’t have to.

I haven’t had any problems (that I know of) with HT and Renoise, since it was “disabled” in the early alphas. What are the problems with V-Station?

Right, then its a bit difficult to say what is the optimum settings then.

So if I understand this correctly, renoise attempts to deactivate one of the
virtual cpu’s when it starts. But it is best to not have HT enabled. But it could work with a HT enabled install anyway…

The hardwaresite in mention recomends to have HT off, and installed with the HT in disable mode. For Media computers (video/dvd/graphics) I’ts correct for a musicstation aswell i should think.

This is nice to know for those of us who have or are thinking of P4’s
Right now, HT must remain off… All the way.

Groovy. Could this be line47’s problem? that his HT is set “on” ?

nfryspys

sure thing. HT really starts to shine when you throw some video encoding jobs at it or if you do a lot of multitasking in general, but i was totally relating to renoise only usage in my post above.
i wanted to clarify, that there is no use for HT concerning renoise and that all what is does is to create problems.

me neither, but that’s what i actually do all the time.
everytime before having a renoise session, i disable HT from within the BIOS. if i plan to not use renoise, i leave it enabled.
it’s not a very comfortable way of a workaround, but i meanwhile got used to it…

it’s still “disabled” in the current 1.5 final release as well, since you will notice that the renoise.exe merely utilizes one of the two virtual CPUs.
(taskmanager -> processes tab -> righclick “renoise.exe” -> affiliations (first list entry from below) -> only “CPU0” will be checked, whereas “CPU1” is unchecked).
but that doesn’t do the trick thoroughly enough as it seems, because HT is still enabled and renoise just tries to circumvent its usage.

click for fullsize

click for fullsize
note: this error will only occur when HT is enabled in BIOS. if it is disabled in BIOS, V-Station will never crash RNS.

yes, that’s how things exhibit over here.
if i wouldn’t use some certain synths, then HT would be no problem.
but as i do (see screenshot above) problems will be my companions.

no idea to be honest.
on my system, HT does not influence performance but stability.
so if i use synths that have no problems with HT, they work just as well as they do when HT is disabled, performance-wise.

Yup, I know. What I meant was I had problems at first, but since the version that shut off CPU1 everything works fine.

I use V-station now and then but never got this error. Do you have a way to reproduce this crash keith?

uhm, yes and it’s quite simple even:
step 1 load V-Station
step 2 you’re set - renoise just crashed. ;)

hmm so this makes me wonder why it crashes immediately over here and works fine for you… scratcheshead
but it’s definately related to HT on my system, because as mentioned before, it works like charm with HT disabled.

Hum… I have not had any problems with HT. But I guess it wont be much of use in Renoise.

btw… The only plugins that are real multithreaded are the big sampler plugins like Kontakt 2.
So if you got a dual cpu you will get a performance boost, even if the host (renoise) does not have an multithreaded engine.
I dont think this will boost any performance using only HT though.

But… What will be the deal with Renoise in the future? Multicore cpu’s will ‘demand’ Renoise to get a multithreaded audioengine pretty soon?
I asked a plugin developer about this…
He said almost all plugins support multithreaded hosts. Which means that the host will distribute the load on to the different cpu’s.

I hope this is something the developers of renoise will start taking into account soon.
I can see myself using dual dualcore cpu’s (4 cpu’s) in just a year from now. B)

cheers

true pysj, dual- or even multicore CPUs are the future as it seems, since both AMD and Intel are planning production of such CPUs in the near future.

but i guess it’s a hell lot of work to optimize renoise for multi-processor environments. :(