I don't get the metronome

[s]Ok so here’s what I’m trying to do. I want to just… play stuff on a midi keyboard and it be recorded in the pattern editor, rather than work out the melody in my head slowly and program it in. I want to just play it. Of course this requires hitting play with record enabled. I’m going to need a metronome to keep me in sync with the track, and I need a precount to give me time to swing around to my keyboard.

So there’s a metronome, with a precount, and it does not behave anything like what I’m used to, and I don’t really understand what I need to do to get it to do what I want it to do. With precount enabled, to say 2 bars, I hit play and it just… plays 2 bars, over and over forever. The precount does not go away when you disable the metronome. I mean, the sound of the metronome goes away, but it still just loops the first 2 bars over and over again forever.

This mystifies me. What is the purpose of a precount that, is in no way “pre”? It’s just, the first 2 bars of the pattern. How do I get it to count 2 bars BEFORE playing the pattern, and then play the pattern?[/s]

Nevermind. As always I will blame lack of sleep. Of COURSE I wouldn’t notice this until immediately after posting, but apparently I accidentally hit numpad enter at some point and turned on block loop.

I’m running Renoise on a Macbook, so I don’t have a numpad key. I have the same question, but for the Sample Editor. I’m recording guitar parts as samples so how do I get a pre-count for recording? And also, -this may be a dumb question, but I don’t have Renoise open atm, how do I turn off take-looping in the Sample editor? I can only imagine setting a longer sample length and stop my recording before it loops =/

Enable precount by selecting in Options > Metronome Precount Enabled

This is the tool you’re looking for: http://www.renoise.com/tools/auto-clone-patterns

First: I did that, but I don’t get a precount, at least not in Sample Editor, that’s the problem.

Second: Thanks, looks like the perfect tool!

Make sure to enable Edit Mode in the pattern editor at the same time.

Also did that. Now, I did get to record a sample, but only after the pattern was already looping, so I could push the “start recording” button somewhere half way into the pattern and it would count down for me. Does this mean there’s still no pre-count?

By the way I need to get this straight in order to record more live instruments and vocals in the future :)

http://www.youtube.com/watch?v=z3X62JpNXBA

Thanks! I see what my problem was.
Apparently I only get the precount when I’m recording with Pattern Editor view open. So no precount in Sampele Editor view, got it!