I have click or pops within the song after rendering

Hello, I have a problem, when I playback my song I her no click or pops but after rendering was done to a wav file I listen and hear clicks/pops are there.

But I don’t her them when I play the song in Renoise, what going on?

could there be a problem when rendering with a limiter on the master channel?

I tried real time and offline

after rendering was done to a wav file I listen and hear clicks/pops

What are you using to play the WAV file?

If you have rendered a 32-bit WAV then some players may not handle it properly or may produce distorted output.

Can you upload a small example XRNS song and a WAV render to compare?

Im on linux and use plugins you might not have, there is no part in the song where I don’t have carla with wine-rt.

Pops occur always at the same time, there could be a bug in Carla but I’m not sure. cus normal playback works.

I also have windows on this machine and I think I may have run into this problem there to one time. I tried 32-bit and 24-bit no difference

I can upload the wav file, but the song will maybe be useless unless you go thru all the trouble installing all my weird plugins

wav file

http://www.filedropper.com/bugtest

song file

http://www.filedropper.com/bugtest_1

Might be a problem with some plugin. I’ve also notived sometimes plugins behave different on render than they do realtime.

I can upload the wav file, but the song will maybe be useless

Yeah, I’m on Windows here, so I won’t be able to fully test the song unfortunately.

I can still check out the WAV and see if there’s anything strange going on.

A small snippet should be fine, doesn’t have to be the whole song.

Quickly checking the WAV now…

Not being familiar with your music, which seems to be quite experimental and noisy to begin with, it’s truthfully a bit difficult for me to spot any major problems that may be lurking in there.

One thing’s for sure, though… The waveform is really squashed to hell, haha.

The heavy overdriven sound itself is not necessarily a problem, but I think the fact that you have it fully normalised to 0dBFS may be partly to blame.

Some DACs do not handle full 0dBFS signals very well, and especially if there’s any resampling involved at some point, it may result in “inter-sample peaks” that actually exceed 0dBFS and clip the output.

Here’s a pretty nice article that goes into more detail: http://www.musictech.net/2012/09/10mm-no211-inter-sample-peaks/

So, my first tip would be to simply avoid normalising to 0dBFS, and instead leave yourself a little bit of room. I find -1dB to be plenty for my needs, but I’ve seen others recommend a bit lower like -2dB or even -3dB.

Either way, try to simply lower the volume of your output by a small amount and see if that helps. If it’s the limiter on the master doing it, then simply drop the levels down a bit.

I need help, I’m facing the same problem, tried lowering the final volume in the master, removing its limiter (as @dblue suggested 4 years ago), exporting 16 and 32bit, rendering realtime, enabling dithering, everything. the pops and clicks occur in the rendered song always at the same parts of the song, and everything is normal in playback. I’m considering using stereo mix or smth and record the playback into audacity, idk… i just wanted the song to sound exactly how it sounds in playback mode, but rendering “realtime” couldn’t achieve that so I’m really frustrated. I was hoping I would release this song today, but I’ve spent the last 4 hours trying to figure this thing out. please, somebody help me!

do you have effects/dsp turning on and off in automation? that caused clicks to me in the past.

yeah I had, but I already removed all of that cause it also caused me problem in the past and I thought it might be the problem… it wasn’t, though… :confused: btw, i just used the stereo mix into audacity workaround I mentioned cause I really wanted to finish this track tonight, so… it “worked”… but yeah, that bug is so annoying, if anyone has more ideas on what could be causing the problem let me know here pls…
thanks for your reply, btw! :slight_smile:

Are you using jack audio?

not at all, i dont even know what that is tbh

if you like, you can upload your .xrns, i can load it in my renoise and take a look?

It’s a audio routing system, where you can route audio from and through your apps and devices and you can even add plug-ins. It even works on my Windows machine.

QjackCtl - JACK Audio Connection Tookit - Qt GUI Interface (sourceforge.io)

Its a plugin or a sample that interrupts the signal in a bad way… You can use the painting tool to remove it. I looks like a discontinued part in the signal. It will cut off the current if its too much for the sinc function.

It makes like a sine wave between the dots, not really, to make the story short… You have to figure out where it comes from. We can’t know that. Also xruns is the same but its the whole buffer that’s missing. Same thing happens.