Id like to use Kirnu Cream or SugarBytes Thesys in Renoise

id like to use both of them in renoise. will that be possible in near future of renoise?

Have a feeling you’re not going to get a definitive answer from the devs; they have always (except for one occasion?) been pretty strict on themselves to not provide information on new features they’re working on; largely to avoid user disappointment if the feature doesn’t make it into the next version of Renoise or the feature doesn’t turn out to be quite like what people were expecting.

Nevertheless; you have options for using Cream and Thesys with Renoise.
If you want to run them WITHIN Renoise, you can do so using the plugin version of Bidule.
However, you’ll have to purchase a license for Bidule ($95) to do that.

Some other somewhat similar plugin-hosting-plugins which may solve your problem are:
MUX (49 Euro)
VSTForx (15 Euro)
Metaplugin ($49)
EnergyXT (39 Euro)

Mind you; from my experience with Bidule (a lot of it), and my guess as to the capabilities of the other plugins I mentioned, you’ll have to either also have the instrument(s) you want to control with Cream and/or Thesys loaded (chained) in the same plugin, OR as is possible with Bidule (not certain about the others) route the MIDI from Bidule (using one of it’s virtual MIDI outs or another kind of virtual MIDI out) out of Bidule and back into Renoise so it can be assigned to control whatever you want to control on another track.

thx for the infos dformd…i try bidule now. expect my questions for it hehe :slight_smile:

EDIT: Metaplugin is my choice…its easy to handle and does the job. many thx for the help!

…and metaplugin sux…plogue bidule is the way to go… :)/>

Interesting thread, could you explain a bit more about the plugs you were trying to use, why they didn’t so what you wanted them to without metaplugin/Bidule?

Also, how did Bidule solve it better than metaplugin?

This could be useful to others. :)


ok…i tried metaplugin 1st but it creates bad behaviour on the hosted plugins gui. for example i tried to connect the cream arp to omnisphere. then i tried to move the adsr faders in omnisphere which jumped up and down and i was unable to get them into the position i wanted. then i tried the same with vanguard. as vanguard is a 32 bit plugin (and i used the metaplugin x64 host), i had to create x64 aliases with the jbridger tool. but the problem is, the gui of vanguard (x64 alias) wont show up in metaplugin, so i tried to modify the gui settings with jbridge. i can do what i want - the gui wont show up in metaplugin, where it does if i load the plugin directly into a renoise instrument slot. ok…i wrote an email to the support of metaplugin creators (ddmf) and got no answer (nice company). now i decided to use plogue bidule and voila…now i can route the cream output to every plugin i want (without any bugs).

Hey kola cell; I’m happy to read you found my suggestion(s) helpful.
I know Bidule is a chunk of cash compared to some other plugins with the ability to host other plugins; hence I felt I should offer some other possible options, but if you spend some time exploring Bidule I suspect you’ll find that it’s capabilities are pretty freak’n enormous.
For example; with regards to MIDI routing; there is a whole world of possibilities for extending the already substantial functionalities of Thesys and Cream; like filtering and splitting their MIDI output, rerouting specific notes, tripling up Thesis, converting Cream’s note output to CC values to change Thesis parameters based on specific conditions, condition-based MIDI buffering/looping, etc, etc… The possibilities can be kinda mind-boggling. On the other hand, I’ve found it pretty damn great just for straight up plugin chaining; quite solid; hope you have a similar experience with it. Also, in case you haven’t noticed yet; the parameters of any plugin hosted in the Bidule plugin can be mapped to Bidule’s plugin parameters for control from Renoise.

Fire away!

ok…1st of all i recognised that not all of my plugins are show up in bidule…for example refx nexus…

hey, apologies; didn’t notice I had personal messages.
How strange; regarding nexus; I’ll download the nexus demo (if there’s a Mac version) and see if I have the same issue.
Never encountered plugins not showing up in Bidule, but occasionally look for them under the wrong right-click sub-menu; like VST instead of VSTi, or VSTi instead of AU.
Back in a few minutes…

Well, it appears reFX don’t offer demo version downloads, so I can’t test it out for you.

However, I did notice that Nexus requires a USB eLicence key, so if you don’t have your’s plugged in, that would likely be the reason it’s not showing up in the plugin list.
I (strongly) suspect this because I own the Antares Vocal Toolkit (plugin bundle) which requires an iLok (USB) key, and occasionally I search for one of those plugins, can’t see it in my plugin list, and then realize it’s because I don’t have my iLok plugged into my computer.

I’m pretty sure the owner(s) of reFX feel/think it’s one of those companies that has in the past been brutalized by pirates, which is likely why there’s no (crackable) demo versions of their latest software and it’s all mail-order and USB eLicenser activated.

err its true…lol…nexus wasnt enabled through the elicenser because i bought steinberg padshop pro …had problems with the addon for it and thus i deinstalled the licenser shit - so thx for you hint hehe (edit: i thought elicenser would save it in the cloud?!)