Ignore Renoise Midi In when in Record Mode

I’m sending Midi Data from Ableton to Renoise via the Renoise Midi-IN on different Midi Channels to different Instruments in Renoise, but it’s really bothersome that as soon as you go into record mode all the Midi Data coming into Renoise Midi-In is dumped into the Tracker Grid.

Would really like a option to make that not happen, so I can trigger Midi clips in Ableton and have them play Instruments in Renoise, but still can work in the Renoise Grid in record mode.

I’ve set all 4 Midi Master Keyboard Inputs to none, so I assumed that wouldn’t happen, since you can actually set the Master Keyboard to “Renoise Midi-In”, which I would assume would then make Renoise behave the way it always does… erm… so maybe a bug?