Increasing the pre-delay of the MIDI Clock Master

I’m having trouble syncing my external drum computers up with Renoise. With my current audio settings, the maximum pre-delay is a mere 7 milliseconds. This is not sufficient even without using any plugins (which make the delay way worse because of the plugin compensation).

The documentation states that the following is the reason for this limit:

Please note that the smallest possible negative latency is limited to the current latency of your soundcard. If you need further negative latency, you can increase your audio latency in the Audio Preferences.

Isn’t there another way to increase the pre-delay of the MIDI Clock Master? For example, in Ableton Lite I can increase the pre-delay per MIDI out port to a whopping -300ms without any problem.

I’m aware of workarounds that are posted in other threads, such as routing all non-hardware tracks to a send track (or making a group) that delays the audio, but this quite cumbersome and also results into metronomes not being sync any more. It would be great if we could just adjust the MIDI sync per port like in Ableton.

1 Like