Instrument's quantization setting keeps reverting to "Bar"


Currently have an issue in 3.1.1. Instruments’ quantization setting keeps getting set to “Bar” (when it should be “None”) when I freshly load the project file no matter how many different ways I try to save them. Neither saving the project file nor saving the instrument itself seem to prevent this from happening. It is weird because I have loaded up a file and then before playing checked to see that the quantization was at “None” like it should be, but after I start playing the track it always returns to Bar and I have to manually set it back. I have no idea what is causing this - I have tried reproducing the issue to figure out what causes it but I can’t. It only happens when I am not observing it, which is weird

I use Renoise for live sets so this is a pretty dicey thing to have going on. If the track only has one instrument or something then it is not that hard to just mouse over to the instrument and change it back mid-track on the sly, but aside from seeing myself forgetting to do this 70% of the time, I have a couple project files for live stuff which were made a very long time ago and have slowly been added onto since then and thus have like 3+ instruments I gotta worry about (and have forgotten which one does what) so it’s a bit of a hell situation to think about.

Bit bummed because I finally decided to move on to 3.1.1 from 3.1 for live sets and I can’t really figure out why it’s going on. It didn’t seem to occur when I tested that everything still worked fine on 3.1.1 so I don’t know what caused it to start now.

Just to re-iterate I am talking about the instruments’ individual quantization settings, not the quantization setting on the Edit page.