Intermittent Renoise crash due to UNO synth dll

Description:

  • Intermittent crash or Renoise due to IK Multimedia UNO Synth dll, which is a dll for use with hw synth.
  • Seems to crash at random whenever doing something related to this plugin (and UNO hw synth).
  • Unable to reproduce, issue appears intermittent (today 3x though in 1hr).

Expected results:

  • No crashes :slight_smile:

Actual results:

  • Intermittent crashes, loss of song & progress.

Extras:

  • Reported issue with IK Multimedia (pending response).
  • Renoise should be latest version
  • UNO Synth DLL is latest version
  • UNO Synth (hw) is on latest firmware v1.1.4)
  • Section from log:

Feedback requested:

  • Would appreciate recommendations & suggestions for this issue.
  • Thanks in advance!

============================================================
Version : Renoise V3.2.0 (Aug 26 2019)
Date : 2020-09-18
Time : 16:57:10
OS : Windows 10 (x86_64)

VstPlugs: Caught exception in VSTPlug::SetParameterValue

Warning Message: Ouch. The VST plugin ‘IK Multimedia: UNO Synth Editor (from IK Multimedia)’ crashed in VST event/function: ‘SetParameterValue’, Thread: ‘AUDIO Slaves’
Warning Message: IMPORTANT: This is a fatal error. Please save the current document under a !new! name to prevent losing important data. Renoise will silently ignore any following errors from this plug-in.
Warning Message: DO NOT IGNORE THIS ERROR; DO NOT CONTINUE USING THE PLUGIN. THIS CAN DESTROY YOUR SONG OR CAUSE OTHER RANDOM CRASHES AND PROBLEMS!
Warning Message: It’s most likely that this is a bug in the VST plugin, so please report this problem to the authors of this plugin in order to get the problem fixed!

KeyEventHandler: Unknown DirectInput key pressed. ScanCode:‘0xB7’

KeyEventHandler: Unknown DirectInput key pressed. ScanCode:'0xB7’Log.txt (7.4 KB) renoise-uno-crash-error

I actually had that synth set up in Renoise for almost two weeks, because I loved the sound and I went out to buy one, because they were on sale, and so amazing sounding with a vst editor. Sadly, my UNO hardware was defective and I returned it for a refund.

The plugin I had 0% issues with. I would suggest:

A. Updating to the latest version of Renoise - v3.2.2

B. Unchecking the GUI compatibility - which, irrc, must be done for that particular vst

The plugin options are on the plugin screen, in the question mark outlined by the yellow circle in my screen shot, the GUI compat is in the other yellow circle

GUI compat

Thanks for the quick response :slight_smile:

sorry to see your experiences with the UNO ended abruptly. How come you asked for a refund if you liked it? :slight_smile:

Right, I’ve done the obvious to move to the latest version of Renoise (hadn’t yet noticed a newer version was available). I wasn’t aware of the extra settings & options for VST plugins and I checked it out. The option you’re referring to isn’t selected (by default). So, I made no changes there.

Let me have another go today and see if the new Renoise version made a difference. :+1:t2:

Refund because of guitar center… they were being all nasty about me not knowing what I was doing…

Whatever