Invisible Vsti's

CAn only find one “other” version of this question on here, but the reply to fix the problem doesn’t seem to work!

Ive got my VST Directories set up properly, but only 2 vst effects are showing up! Ive switched the directory to different folders containing vsts, nothing! strange thing is, when I first got the demo version of renoise I’m 99% I can remember them working.


Done it hundreds of times, it scans them (it finds the effects but none of the instruments, the instruments work in oth daws Ive got installed


got there before i did. in other programs VSi’s and VSTeffects are handled in the same way but renoise treats them seperately (as it prbably ought!) so yeah, as shown above really.

instruments in Instrument Settings and effects in Track DSPs.

When I go to VST Instrument Properties an click its empty, it just says ‘None’


Hmm, strange…

Please check whether the check button at the left side of the vst directory setting is on.

And try trashing the CachedVSTs.xml and CachedFailedVsts.xml file in Renoises preferences folder at;

c:\documents and settings\yourusername\application data\renoise\v1.9


~/Library/Logs/ (~ = your home folder)

Then restart Renoise and please check whether Renoise will scan your vsti’s while start up… :huh:

Box checked, got rid of the logs, still nothing!


hmmm strange, when I try to open the Cashed/Failed xml’s osx just open “Big Bang” ‘4 in a Row’!

I am puzzled

Cached Failed VSTs

<?xml version="1.0" encoding="UTF-8"?> /Users/simonokeeffe/Library/Audio/Plug-Ins/VST/CM Studio Plugins OSX/01 CM-101 OSX/CM101.vst/Contents/MacOS/CM101 false /Users/simonokeeffe/Library/Audio/Plug-Ins/VST/CM Studio Plugins OSX/02 SR202 OSX/SR202.vst/Contents/MacOS/SR202 false /Users/simonokeeffe/Library/Audio/Plug-Ins/VST/CM Studio Plugins OSX/03 DS404 OSX/DS404.vst/Contents/MacOS/DS404 false /Users/simonokeeffe/Library/Audio/Plug-Ins/VST/CM Studio Plugins OSX/06 CM-303 OSX/CM303.vst/Contents/MacOS/CM303 false /Users/simonokeeffe/Library/Audio/Plug-Ins/VST/CM Studio Plugins OSX/10 Energy Pro OSX/energyCM.vst/Contents/MacOS/microgy false /Users/simonokeeffe/Library/Audio/Plug-Ins/VST/TauBassline_OSX/m-drive.vst/Contents/MacOS/M-Drive false /Users/simonokeeffe/Library/Audio/Plug-Ins/VST/TauBassline_OSX/TauBassline.vst/Contents/MacOS/TauBassline false


Cached VSTs

<?xml version="1.0" encoding="UTF-8"?> PulseModulator PulseModulator false 1095004269 0 false true true LiveCut LiveCut false 1819698036 0 false true true

os x 10.4.10

2GHz Intel Core 2 Duo

your not the only one!

ya they work in a demo of ableton.

okay Im gonna download, some newer vsti’s an see what happens!


download some more vtsis still nothing!

ableton demo, is picking the new ones up too!


any other ideas, this is wrecking my head

Sweet as, guys thats working now!



maybe Im being dumb and or this feature isnt in 1.8 but…

IM not seeing a time line or a hex line in the Sample Editor

yes, this has been introduced in 1.9.

(read the whole changes log here)

nice one man!


Ok, I had already removed the Muon vsts, now when I open the xml it doesnt seem to have scanned the other vsts at all!


As Bantai already said: Please make sure that you actually have the intel versions (universal binary) of the VSTs installed.

That they load up in the Ableton Demo might be because you have installed AU (Audio Units) instead of VSTs? Renoise does not support AUs yet, but Ableton does.

Try to install this free (and great) VSTi to see if that shows up in Renoise:
Here is the direct link to the VST installer:

If it doesnt, then maybe you have set a wrong path in Renoises VST preferences? Please check them and correct them if necessary.
They should be (and are by default):

  1. /Library/Audio/Plug-Ins/VST
  2. /Users/YOURLOGINNAME/Library/Audio/Plug-Ins/VST

Most VST installers will use the first path…

I don’t think that this is a multi core problem as multi core problems mostly only occur when playing the VST - not when simply “scanning” them.

Cool thanks

I’ll try that later, they are runnin gon v1.8, not too up on the “intel”, “universial binary” stuff, but will check it out!


ok I d/loaded that vst, installed it and when I opened Renoise, the vsti’s that werem’t working, worked?

problem solved, not sure how!



OKay, so IM sitting down last night, with all my vsts working, when suddenly I get an error message from Renoise, it says its saving a crash backup and shuts down, when I try open it again all the vsts and vsti’s arent being read!

also, something else I’ve discovered that seems to be related to this problem, is that I can’t open any .xrns file, I have to open Renoise first.