Is anyone else experiencing this issue with u-he Zebra 2 in Renoise?

I was wondering if anyone has experienced this or something similar in Renoise with Zebra 2 or other VSTi / AU plugins. My issue seems to be localised to when using Zebra 2 in Renoise (both in Renoise 3.2 and the new 3.3). I don’t have the issue in Reaper. I’m on Mac OS Catalina.

The issue is that none of the dropdown menu selections in Zebra 2 work, the parameters just won’t change when selected from the menus - this applies to patch editing only, not preset selection. The issue exists in AU, VST2 and VST3 instances of the plugin and only with menu dropdowns in Zebra 2, and not with menu dropdown selections in other plugins I’ve tried.

The only time I can get the parameters from the menus to change is if I choose to enable keyboard at the bottom of the plugin window. The only problem with this solution is that I have to continually turn enable keyboard on / off between when wanting to use the qwerty keyboard to play notes or edit a patch. Also, this behaviour seems to only have occurred since I upgraded the OS on my crumby old mac, so I’m thinking it might down to using the most recent version of Zebra 2 with Renoise which I may have not been using before I performed a complete reinstall of my system, DAWs and plugins.

I was wondering whether if anybody else has experienced this kind of thing before in Renoise and what the possible cause could be. I’m also onto u-he’s support to see whether it might be a bug in Zebra 2.

Any suggestions or advice would be really appreciated.


I have the same yes. For some reason Zebra needs keyboard input for the mouse to work properly…

u-he suppot have reported back to me saying it’s a bug in Apple’s OS and the plugin window needs to be fully focused in order for the plugin to react, so I’m assuming Renoise only puts a plugin window fully into focus when the ‘enable keyboard’ selection is checked?? It’s strange how all the knobs, buttons and anything that isn’t a menu works without ‘enable keyboard’ checked. My only conclusion now is that the way Zebra 2 handles menu selections is based on text objects and therefore require keyboard focus ‘a full focus??’ in Renoise in order to function correctly. I wonder why this isn’t the case with other plugins which use menus to select certain options, such as TAL’s Sampler.

Frustratingly, u-he have told me that this issue isn’t a priority for them to find a solution to. So I either need to hope that there’s a solution to be had in Renoise or accept I can no longer use Zebra 2 until u-he take on the issue or Apple fix the bug, which according to the link u-he provided me with has existed since OS X Sierra, so unlikely it’ll get fixed by Apple anytime soon.

Yes, I find this annoying, too, and also got the same answers from taktik and u-he. I think you can at least use the mousewheel to switch values. Ok, listening to the options in between might be a bit annoying, but I think it does not loose any setting.

Ah Damn I’ve been having this issue for ages and even had a back and forth with u-he support about a year ago trying to resolve this. Somehow I got Zebra2/HZ and Satin to work with the context menues. But Hive, Repro 1/5, and Diva are still having the issue. Only thing I can think of that I did different was completely removing all U-He plugins then reinstalled them, enabled sandboxing for plugins, then disabled it. It stuck with Zebra and Satin for some reason. But it’s good to hear “enabling keyboard” makes it work, I haven’t tried that this whole time I’ve experienced these issues. Been sticking with the mouse wheel to change parameters which isn’t the most efficient in the more complex areas of these synths.

Edit: Upon further inspection, context menu only pops up for the modulation matrix in Zebra. Everything else requires enabling keyboard or using scroll wheel. Satin just works flawlessly.

Edit 2: mini rant, Apple needs to stop fucking up OS level stuff that interfaces with audio plugins. There’s also an issue on iOS rn when loading AUv3 plugins in host apps like AUM and Drambo where the plugins don’t show up half the time unless you do a hard reboot. They really need to do some more quality control on both MacOS and iOS regarding audio plugins…

It’s sort of good to here it’s not just me experiencing the issue but also annoying that small things like this are an ongoing problem specifically with u-he plugins which let’s be honest aren’t cheap! I can only imagine it’s not a quick bug to fix for them and they have other priorities. I hadn’t actually tried using a mouse wheel, I normally use the trackpad on my laptop but just tried it and it seems to be a viable albeit a bit fiddly solution. I guess the only problem with this solution is you can’t see all options available in a menu and just have to remember what each menu contains. I at least prefer this method to using ‘enable keyboard’ which becomes tedious if you’re only using the qwerty keyboard to play notes.

I’ll also try the reinstall and sandboxing todkon mentioned, just in case it works for me.

Thanks to everyone for all the advice :slight_smile:

yeh it’s frustrating with Apple in that they are forever tweaking their OSs which cause problems like this for us audio folk. I guess this is just one of the major drawbacks of using software for music production and the reason why I’ve been turning to using hardware more these days. I stopped buying plugins a while back because I can do so much in Renoise natively - now I only have Zebra 2 and Tal Sampler. Reason is tempting now VST3 is available but I’m afraid to spend that much money on software that in a few years probably won’t work correctly on my system and I’ll have to drop more cash to keep up-to-date, or have to upgrade my computer to run an OS that will continue to run all my software. Oh! and don’t get me started on Apple’s hardware issues…

I enabled three finger drag on my MacBook track pad that lets you drag and twist the knobs, and two finger up/down & left/right for scroll wheel. Also, you can still see the contents of the content menus which kinda gives you an idea of how many notches of parameters you need to nudge using the scroll wheel. But yeah, I totally agree, I feel most comfortable playing my keys in QWERTY as well, it does get annoying having to manually switch “enable keyboard” to play notes and sound design. I wish there was a way to bind that little checkbox to a Renoise keyboard shortcut… Anyway, I don’t know if you caught my edit, but it turns out that my steps to cure the issue didn’t do anything, it just made me think it worked since Zebra allowed me to change parameters in the context menu solely in the center matrix.

The reason I even got a MacBook in the first place was because they were usually the best option for music production. But now they’re dicking around the OS way too much that it’s becoming annoying using their platform. The fact they’re eventually going to completely abandon x86 worries me gravely due to how much software will become obsoleted, remove the ability to use Bootcamp, and totally ruin the whole reason I was down to get a Mac in the first place. That being that it was x86 instead of PowerPC so I could run Windows, Linux, and MacOS on the same computer while having some of the best audio software. Anyway lol I won’t rant too much, I just don’t know what’s going to happen when my 2013 MacBook pro shits the bed. Probably just gonna move all my production to my gaming PC at that point. Also, I totally feel ya with Reason. It’s tempting, my good buddy uses it and swears by it. It’s fun to use. But I like Renoise because of the fair and affordable license that doesn’t make us spend $300 annually for major version upgrades.

Cool thanks, I’ll have a muck around with my trackpad settings. I agree a keyboard shortcut to ‘enable keyboard’ could be useful.

My MacBook Pro is hanging on by a thread at the moment. It’s one of the 2012 ones that suffers from the loose RAM slot movement issue, so if pick the laptop up in a certain way or if pressure is applied to certain areas of the bottom chasis it can freeze and forces a restart and you lose all your work! I have managed to reduce the likelyhood of this happening with a bit of DIY but it’s not perfect.

I feel your pain with the abandonment of x86 and Bootcamp. I have a client who has been ticking over a fairly old mac system with Cubase with tons of libraries and plugins and he’s been gradually loosing it all and having to shell out a shit load of cash to bring it all up to date. Funny thing is he has an old Roland arranger keyboard and a bunch of hardware from the 80’s that still works to this day!

Reason does look great, I used it way back at version 2 I believe and it has come a long way since then. Like you say, this kind of software means you have to spend something like $300 each year whereas, at least Renoise, and I think Reaper also, have really decent and fair pricing / upgrade models. I also like the idea of FL Studio’s buy it once model but I’ve never used it to know what it’s like.