Jack 0.10x.x Unsupported By Renoise

I’ve updated jack to 0.109.2 but when connecting Renoise i get a protocol mismatch (16 vs 22)
Renoise also says that it can’t initialize jack but that is due to the client connection process that is being terminated because of that.
I also had to upgrade jack control to 0.3.2 in order to get it connected…
It seems that protocol additions or changes for jack support are required for Renoise to have the latest jack server supported.

I wonder how much of this update issues may come in the future.

I can assure you that Jack Control 0.2.2 refuses to work with jack 0.109.0 and higher and Ardour refused to work as well.
Ubuntu Studio comes with Jackqtl 0.2.2 out of the box and Jackd 0.8x or something (don’t remember anymore).
I was forced to upgrade jack because Lash demanded Jackd >=0.99. As soon as i did that, Jackqtl refused to connect and Renoise refused to connect.
When qtl refused to connect there were no error messages except for a shutdown event 254, it started Jackd, called the Alsa driver and as soon as Jackd was up it got shutdown instantly again.
This kept me mindboggling for a half of an evening because i had to update a few other options in order to compile Jackd.

When i opened Renoise i suddenly got a client protocol mismatch event in the message window.
So that part made me thinking and i downloaded the latest JackQtl sources and installed QT 4.2.3 libraries (using synaptics as downloading and compiling from scratch and make install installed QT libraries but appearantly not where JackQtl would expected them) and compiled JackQtl 0.3.2 and JackQtl 0.3.2 now runs fine with Jackd 0.109.2.

Having to update JackQtl to make JackQtl running is a fact so if Jackd 0.109 should be downwards compatible then i can tell you just for this fact alone:it is not. Any software compiled with Jackclient < 0.99 (or less) probably fails as well.

I guess Renoise has to be compiled with at least jack client 0.109.0 sources to be compatible (at least 0.109.0 had a few API changes in the client protocols).


# New release : Jack 0.109.0
 Submitted by pieterpalmers on Mon, 2008-01-14 19:26. Changelog  
 API changes:  
 * add jack_thread_wait API  
 * remove port_(un)lock functions  
 * add new time APIs  
 * add port aliases  
 * add new client registration callback  
 * add port connect callback  

For sequencers like Ardour i can manually recompile with Jack to resolve the problem but i can’t recompile Renoise.

Great then i’ll have to figure out what i messed up…

Following the README and INSTALL files doesn’t always keep you safe from problems… (In fact it doesn’t even always deliver what is promised you to be delivered.)

Thank you Lash. :wacko:

And thanks for testing Jenner.

I have updated Jackd through recompiling and installing it (sudo ./configure, make, sudo make install)

But also installing QT 4.2.3 after downloading it from techtrolls did not installed the QT libraries, not untill i used the synaptics package manager and found out that QT 4.2.3 libraries were the only ones not installed.

Maybe my assumption that everything is included in the original sources is wrong, but i don’t check this thoroughly.

I will check if the Jack libs have the latest update in the package manager, if not, then i have to figure out where to get those and compile them.

These cases are usually that you have to manually add the correct PATHs as parameter to the MAKE INSTALL script (or configure script) if they are different from the default locations.

Let me just try updating the libraries first and see where i get, then i’ll submit the logs.

Though i’m just still wondering why the latest JackQtl does work after compiling, this part made me thinking about internal application dependancies.

Okay here is the update…
That latest jack version i could install was 0.103.0, i reinstalled jack 0.103.0 and so i did reinstalled the libs.
It did not worked out.

appearantly the applications that are compiled from ground on install in /usr/local/ by default while in Ubuntu Studio all applications are just plainly installed to /usr.
So i copied all jack libraries from /usr/local/lib to /usr/lib (including the configurations from the pkgconfig folder) and it worked out (i took care i copied the jack 0.109.2 compatible libs to the folder that Renoise expect them to be).
If there is one thing that would be nice is that packages that compile would actually check what library and bin folders are really used instead of assuming a certain default.
Or does this exist but have the ubuntu studio developers forgotten to set some default paths environment?

Just seen from a point of just an ordinary user, i don’t want to deal with /usr/local and /usr folders at all.
It is already hard enough to deal with upgrading specific packages manually just for the damn sake of dependancy packages.

Like said earlier, things are not as obvious as INSTALL or READMEs would like to make you believe.

i just heard yesterday about:

‘build essential’
‘apt-get build-dep [source pkg]’

still not sure if orwhat build essential is doing but,

the build-dep apt-get function helped me out so much.

now if i could only figure out how to get around the “don’t have the ~linux/version.h problem”, when i ./configure

It is probably somewhere written in the “Linux for dumbasses” but i haven’t found the “How to find Linux for dumbasses for dumbasses” manual yet.
thx for the additional info.