Just Registered - Now Fx Don't Work!

I just registered and switched to ASIO4ALL, and it got rid of all latency, but now no FX will work. When I switch back to Directsound, they work fine (with latency, of course). Can someone please help? This is really dissapointing me.

edit: Just realized no vsts are working, instruments or FX. Pleeeeeease help.

Can you give more information, less panic please?

Thousands of users use ASIO4ALL and the effects just “disappearing” but the rest of the application working fine seems a bit odd.

“Doesn’t work” isn’t much to go on…

What soundcard? What version of Windows? What specific effects? Renoise effects or just VST effects? A screenshot? An example XRNS?

Links that may of help?


I’m using Windows XP with the soundcard it came with. This may help a little: I just checked the ASIO4ALL advanced settings and there is no output. It asks if MS GS Wavetable Synth is enabled, but I have no idea how to check. No VSTs work. Hope that helps.

edit: just enabled MS GS Wavetable Synth, still nothing.

Windows XP doesn’t come with a soundcard… it’s software ;) What is the brand of the laptop / desktop?

Can you give some name of “no VST” please? Like 5 that don’t work? Did you try them all systematically? Did you click on the [?] icon and try different settings?

Really, more details, not less, please.


Actually I just restarted and it works fine. I should have tried that first. Sorry to waste your time.

Haha, good times.

[s]The Asio4All does not seem to recognise your soundcard probably.
The WDM device list should display your available soundcourd and it should be expandable (a plus-sign in front of the device name)
When you expand the device, it should show you all inputs and all outputs of that device, also all outputs should be in active state (the play symbol should be highlighted)
You may want to check out the ASIO audio buffer and raise this one a bit higher or check the “Hardware Buffer” checkbox.

Perhaps the “Force WDM driver to 16 bit” may help out as well if your soundcard is offering audio in e.g. 20-bit resolution.
[/s]Too late :P

Haha, thanks even though it was a bit late. This is pretty much the coolest thing ever btw. No latency + virtual amp is sooo sick.

OK rather than make a new thread i’m gonna post here with another problem i’m having. The first time I open Renoise everything works fine, but after closing and reopening later I get no audio. I check the ASIO4ALL settings and there’s no output. I read another thread where someone had this problem, and it turned out that he used Rewire and a component of it Rewire was still running in the background and using ASIO4ALL. The thing is: I never use Rewire. I do use the Line In thing, not sure if that would do anything though. I never had this problem before switching to ASIO4ALL. Can anyone help. The only way to fix it is to restart.

If in doubt, reboot.

We should also post this as first reply in H&S thread:

Have you tried turning it off and on again?

And second reply:

Are you sure it’s plugged in?

I’m not really sure what I would be turning on or off or plugging or unplugging in this case. I closed and rebooted Renoise, the only thing that works is to restart my pc.

Hehe, don’t mind that, it was a joke from The IT Crowd. :D

Our IT dept consists 2 chaps and a lady. We ask ‘have you rebooted’ at least 2 or 3 times a day!

We need one of those looping tapes as well :)

Sorry dij134, I understand your frustration!

Well, i’ve managed to narrow the cause down somewhat. If I close Renoise, play some sound on the internet (Myspace, Youtube, etc), Renoise can reopen and work fine. If I play music in my media player, however (foobar2000 for me) it will not work again. Weird since foobar isnt using ASIO. Maybe if I change the output to something else still I can get good results. I shall try later.