Kaoss Pad 3 With Renoise

Hi,

Can someone help me with this one?

I have this setup with my kaoss pad:
I send the output of a track to my kaosspad instead of the normal mix output.
The output of my kaoss pad comes back into renoise again, but just a few msec too late.
Since I cannot give the input track of the kaoss a negative delay, I tought to give the track sending to my kaospad a neg delay.
Somehow this doesn’t work.
For syncing with the metronome I’m just using a simple kick sample.

What am I doing wronge here?
On what kind of tracks i can or cannot give a neg. delay?

Thanks!
Thomas

Hi,

What operating system are you using? What audio interface? Are you using low latency audio drivers?

Try to imagine a ring with two open ends that just don’t touch eachother. You can move one end to the point where the other end is currently laying by twisting the ring, but the other end will then simply shift the same amount of distance away.
Changing track delays will only help if you are not feeding the results back to Renoise.

If you can lower the audio latency of your soundcard by lowering the buffering, you would decrease the delay of the input, at the expense of cpu resources.
What kind of soundcard do you have by the way (PCI or USB/Firewire)? And your system specs, PC or laptop?

Hi,

Thanks for the reply’s.

I use windows xp and have an EMU 1820m soundcard with asio on a PCI slot.
The computer is an intel quad core.

So I have the master channel where I put all renoise outputs to.
If I like to use the kaoss pad, I’ll send just 1 track to the kaoss.
This returns into the soundcard and is fed back into renoise.

It is obvious this generates a delay. The delay is about 13msec.
I understand it won’t work to give the kaoss input track a negative delay.
But I think I should be able to give the output track that is fed to the kaoss a negative delay.
If this track should play 13ms in front of the metronome, it’s input would be in sync.

I use the kaoss pad in direct mode, not send mode. So like and insert effect with a dry signal when I don’t touch the pad.

I’m new to renoise, but when I was making a track, I found out I could give a track a negative delay.
This worked just fine, so why can’t I use it this way?

The track I send to kaoss is a kick sample. It is the leftmost track in renoise.

My emu is at 3ms.

Thanks
Thomas

Okey,

So the negative delay does work when sending a track to the master, but not when I send it to another output on my soundcard.
The difference is about 13 msec, and when I try to give a negative delay to the track send to kaoss I do heard a timing difference for about the first 3 msec, but it doesn’t reach the desired 13 msec.

I can’t see why it doesn’t work. Now it’s probably best to use the kaoss a send effect to leave the dry signal in sync.
This is not what i want, cause I really like it as an insert effect…

I’ll give it another try and hope somebody has the solution or can explain why this isn’t possible.

QUOTE by vV:
Try to imagine a ring with two open ends that just don’t touch eachother. You can move one end to the point where the other end is currently laying by twisting the ring, but the other end will then simply shift the same amount of distance away.
Changing track delays will only help if you are not feeding the results back to Renoise.
QUOTE

I don’t think this is the case. If I send the kaoss chain a sound that’s to early, it would come back to renoise early too. Correct me if I’m wrong…
I just tested: it only work for 3msec, but it DOES work however

OFFTOPIC:

just a quick tip. for quoting, use [quote name=“Vv”] and [/quote] (without the added spaces before/after the brackets), or simply use the quote-button on the posting-interface.

/OFFTOPIC

hope you get around to fixing your problem, i am planning on getting a Kaoss Pad someday and this thread will hopefully prove helpful by that time.

Thanks for the tip.

This is not only usefull with a kaosspad but for every external effect processor.

I just did the following:
On the first track I have a kick going directly to the master output.
On the second track I have the same kick going through the kaoss pad.
Now there is a sync issue of 13msec.

If I delay the first track 13msec, both kicks are completly in sync.
Now if I delay the first kick 10msec and give the second kick a negative delay of 3msec, both are again completly in sync.
If I give the second track more negative delay, nothing happens…

I hope there is a setting for this somewhere, cause I don’t understand why I can’t give more negative delay to the second track.
For tracks routed to the master, more negative delay works fine till the -100msec…

greets
Thomas

I don’t completly get it, but I solved the problem :) :)

If I set the input track from the kaoss pad to -13ms, nothing happens.
If I set the track sending to kaoss to -13msec, nothing happens…
But if I both set them to -13ms, it’s completly in sync :D
They both have to be set to -13ms or it doens’t work.

I don’t understand how, but it works!
Can someone from renoise explain why this is?

Thanks!

It’s really weird.
In my template song where I did all the syncing I have to put both tracks on -13msec, but with a song I’m working on it’s sufficient to only negative delay the track thats going to the kaosspad. :blink:

I’d like to know why, cause i want it to be consistant…

(sorry for all my posting)

That won’t remove the electronical gap that simply exists between your Kaoss pad and your PC.
If you set the delay of any specific track, Renoise compensates other tracks automatically to adjust their output accordingly. But because you circulate the signal back, Renoise is already compensating the input track for the output delay you have set, so these 13msecs of delay won’t magically disappear just like that.

This is a thing that you have with computers and audio cards in general, specially if you add effects in the chain that has to process your audio.
There will always be delay, the trick is to keep it as low as possible, but whenever delay is caused, it can no longer be removed, only compensated but compensation will only work if you don’t circulate audio-signals through external effect processors and then BACK to the host. If you don’t send it back but simply send all audio (from computer and Kaoss pad) to an external mixer or another PC:then you can sync the audio.

The more effects you use in any DAW (so not just Renoise and depending on what kind of effects and much calculation they need to perform), the more delay you add to the signal.
Reducing the use of effects within the audio chain in your DAW keeps the delay low. Lowering the latency buffers of your audio card also keeps the delay low. The last option causes your cpu usage to raise, because your audiocard has to process the same amount of input signals much faster to prevent overflow of the smaller buffers.

This will never become with negative track delays.
That would be a similar idea of trying to design an electrical current generator that is capable of feeding itself by only requireing a little startup power.

He doesn’t need it to, only to be compensated for.

Track (Send) -> KP3 -> Renoise -> Master
The same as:
Track -> Renoise Master.

All monitoring done at the main output of Renoise after going back into the software.

You should be able to get all audios aligned at the Master channel!

You will not be able to remove the ~13mS delay between what you hear at output and what you are affecting with playing with the device though. Most people can’t notice around 6mS, 13mS you may find a little annoying at times. Less annoying than the audio being 13mS out from that of your other tracks though!

It’s working now and all is in sync.
The only thing I don’t get is why both tracks have to be set at -13msec.
In the song I’m working on this is also the case, although I do can hear a difference in timing adjusting just one track.

Like kazakore said, the reaction of the touchpad on the kaoss is 13msec later, but that is not such a big deal. All the sound comming from the kaoss however is now nicely in sync with the rest renoise produces.

To clarify for vV, this is the setup:

track 1 with kick --> Renoise master --> Soundcard ADAT out 1LR --> Yamaha 01v ch1+2 in --> 01v to Speakers
track 2 with kick --> Soundcard analog out 1LR --> Kaoss in --> Kaoss out --> Yamaha 01v ADAT in --> Line-in Renoise --> Renoise master.

Now I set track 2 on a 13 msec negative delay to compensate AD/DA converters in O1v and Kaoss.

The strange thing is however, just neg. delaying track 2 for 13msec is not enough. I also have to neg. delay the Line-in track (the one where the kaoss is attached to).

All and all: it’s perfect sync now :lol:

Aha okay, i had the impression Kaos input was fed by audio coming from Renoise and then its output being cycled back to Renoise.
If that is not the case than not much need to adjust anything else then.

Edit:Reading Thomas his last reply: It is being cycled. @Thomas: I don’t understand why this can be synced though. I’m just as baffled as you are.

The kaos IS fed from renoise.
And it is in sync now too :yeah:

It is being fed back into Renoise. Just think of it as a DSP with no PDC broadcast (even if values make this an unreasonable comparison), therefore having to put in a manual negative delay to compensate. I don’t see why you think it would be impossible!