Key Bindings Import problem

Usually, when a new version of Renoise is installed, the keyboard configuration is transferred to that new installation. But with the latest version, something seems to have gone wrong.

I’ve tried:

  • opening 1.9.0 and saving the keyboard configuration, then loading it into 1.9.1
  • copying the keybindings.xml from “application data/renoise/v1.9.0” into the 1.9.1 folder

No success so far. It seems that the keybindings.xml will restore itself to default valus whenever 1.9.1 is launched.

Both works just fine here. With which key bindings have you tested this with?

Shows the log some errors about this?

What if you post your 1.9.0 keyboard config somewhere and post a link, maybe there is some error in your old config that 1.9.1 can’t convert.

Thanks for the quick replies!

The log reveal nothing about any problems, but here’s my keybinding.xml file:

P.S: A quick way to test if the import was successfull is to hit SHIFT + any number from 0-9 (they act as channel mutes)

Both, importing and replacing the keybindings with yours works just fine here. There must be some kind of file error (something forbids to write the keybindings for example) to make this happen.

Have you maybe installed some security related tools lately?

Could you send me your log.txt file of Renoise 1.9.1? Maybe I can see there something…

Edit: something happens when I overwrite the keybindings.xml, it seems to restore to a slightly different version.

New shortcuts in 1.9.1 maybe?

I just did a “diff” view on the two files, and it seems like only a few shortcuts went missing, the rest are OK.

I just recreated the missing shortcuts, everything is cool ^_^

So beside of the few missing ones it always worked before?
Which ones are overwritten in 1.9.1?

Yes, I discovered the problem by pressing return (which was re-assigned). So I thought the entire import had gone wrong somehow (should have checked more carefully before filing a bug report!)

I know for certain that Return was re-assigned to “Set Pattern” (Pattern Sequence), previously having been assigned to “Toggle Blockloop Playing”, not sure if there are any other ones I missed or forgotten.