Key Input/interface Lag

im really not sure how to do this since it doesnt happen all the time
it started in rc1 and is still resident in rc2.

i believe it has something to do with the interface
over the weekend i installed win 2000 pro hoping it resolve the issue
i had a theory that xp doesnt work properly with sd ram (even tho i have a gig of it)
so since i have tried everything i could think of aside from changing my screen res to 800/600 -im running at 1024x768
it seems that after running renoise after an undocumentable amount of time,

the keyinput/interface lag becomes basically unexceptable…547a0281c9aa50d

from reading that thread you can see i tried everything and the one thing that worked temporarily was by changing to Big Font.

something i dont quite understand is when i change the refresh rate from 01 to 100 there isnt really any difference i can notice except when using 100 and its acting up the lag is “really bad”

my laptop video isnt all that great but MadTracker 2 runs “perfect” on it.
An now i know that renoise isnt mt2 and to be able to do the gui stuff renoise must using something else -or by my opinion must be.

so this is the reason i bring this here…
to inform you that the key input/interface is creating a big problem
this has been going on way before i started that post i linked to,
and i feel this really needs to be addressed before stable release.

i do apologize for not bringing this sooner.

-btw what are the current system requirements?

okay so after some reading i came up with the idea to start renoise in high priority with a batch file and it has somewhat made things better.
but if you could at least look in to somehow making the gui lighter maybe, it could possibly be the cause if not the solution.

maybe a keyboard driver problem? My MS Intellitype driver caused a lot of problems. I now use the defualt driver in winxp and I do not have any problems anymore. Maybe it’s a solution…

-something really stupid-

What about first letting us know what exactly you mean with “lag” ? You have in no topic described what exactly the problem is.

So what is the “lag” in your case? You are speaking about keyboard and interface lag in the topic. Are the screen refreshes (the pattern scolling) slow or just the reactions on keyboard hits?

Or is it only the time it takes until you hear the samples when playing notes with the computer keyboard? What latency have you set up in Renoises Audio configs? Have you tried to switch between ASIO and Directsound?

Or is everything, for example also moving around in the pattern, slow. What about entering text somewhere in Renoises interface?

Also how slow is it? Unuseable slow, or do you just want to have it faster?

Also what happens if you use a MIDI keyboard to enter notes? Do you have the same problems here?

In general: If you lower the framerate in Renoises GUI options, the GUI and keyboard will react slower. Thats what the option should do. lagging the GUI so that Audio gets more power.

Calm down please. Tom has tried to help some hours after you reported the issue, so there is really no reason to tart with this “noone helps me” thing.

Mainly& most importantly, it is pressing a key 4-5 times before any text is entered into the pattern editor

pressing the up/down arrow keys and it not stopping were you would expect it to stop (resulting in lost time trying to get exactly were you need to be with the cursor)

for instance, when im writing in the pattern editor sometimes i have to actually press the keyboard keys anywhere from twice to five times to actually get a note,effect,vol,pan… digit on the line. basically, like i have hardly any control over renoise.

with the scrolling, when i press the down arrow, it goes anywhere from 20-35 lines, sticks for about 2 seconds, then starts going until the next time it decides to stick which is again about 20-35 lines (its not logical) -after you have used a system for a long enuff time you get to a point where your timing is perfect. so then you press the key for a long enuff amount of time, it stops where you predicted it would.
there has been plenty of times, that i start to think my keyboard is messing up when inside renoise, but in fact, its not at all. i can be in a word processor,chat room ,whatever and type for hours without any kind of hardware error.

No. not at all. when entering notes i can hear everything properly
it only has to do with the text being entered into anywhere in a line.
theres a possiblity that when playing its not keeping time but not enough for me to notice. but as far as i can tell. it only has to do with the interface.
theres no sound problem.

that is a good question, because the problem is there also. when playing it becomes even worse, to the point i have to press the stop button multiple times to get it to stop

Honestly, its important enough to me. to spend the time writing this, communicating this so that i can continue to use renoise past 1.5 stable.
–it is also the same reason i was so furious this morning when seeing that my post had been moved from the bugs section, and Tom commenting about it possibly being a keyboard driver (if it was a keyboard driver, why & how would renoise be the only program that has trouble with entering text? out of all the programs ive run and all of the games ive played on this laptop since before i did the stupidest thing this weekend… -i backed up everything reformatted and installed windows 2000 just to see if i could get renoise working better than it is. and then to see the same problems were still resident-)

but seriously,
i almost Registered Madtracker2 the other day, from being so frustrated from not being able to use renoise

i dont have a midi keyboard, i only use the keyboard on the laptop.

yes i understand that you must also close and relaunch renoise for the setting to take effect.

it would probably be a good idea if i took a video of what i’m seeing
so you could see at least almost first hand

that is, if theres anything that could be done to fix this…
i just know that if there is no fix for this then i w would not be able to use renoise (something ive grown very fond of) anymore.

shit… im to the point that if i could just give you guys another $50 so this problem would go away, i would in a heart beat

that is how much i enjoy using renoise…when im actually able to control it and and me not being a constant irratation

Dont know if I should try to answer to this thread or run away from it, but.

One solution that comes to mind for me is that some of the VST plugs
dont work correctly.
Like the VST “Delay Dots´PHAT pro” who continued to eat up CPU until
it reaches 99% and computer moves veery slowly. This happens when
I played a pattern and pressed “stop”.

The only thing to get the CPU back was pushing the panicbutton several

Computer would be slow but sound still played perfectly. Seems the VST couldnt hande quiet correctly. Problems like those you describe.

Problem was fixed in later version of the plugin.

Then again if noone else of the 1500+ registred of this forum users seem
to have this problem, then maybe it could be something intrinsic to your
specific computer configuration?
If you can make the rest of us understand the cause of your problem, then
it can be fixed.

Other things off the top of my head:
Tried using external keyboard? works to most laptops

Tried disabling every memory resident program.

I had a AMD that would behave stranglely with lags in some games.
I fixed that by disabling the powernow feature.

Thanks for the input choice.

And all this is reproduceable in a clean environment with no song loaded?
Have you tried trashing your config files?
How fast is your computer?

One reason for this might be that the whole GUI is somehow lagged on your computer. The keyboard event input in Renoise is locked to the GUI frame updates.

If you start up renoise, enable the trackscopes and play a single empty pattern at 120 bpm, how much CPU is used by Renoise (as visible in the taskmanager)?

i will try this , after i get all the information together

i havent tried trashing the config files, But i did install 2000 over the weekend so the config files of rc2 came directly from a clean & fully updated install of
2000, basically after i installed 2000 i installed all of the thinkpad drivers then updated with the 20-30 something updates then installed renoise ----pretty much exactly in that order.

another thing i should add that i completely forgot to mention is that in all of my music i use -364 bpm- and -speed 3- (which i think is 3 ticks per line)
i need to use them at this speed because it gives me the pattern resolution i require.

my laptop:

CPU Clock Speed 1132.3 MHz

Long Version:

CPU-Z Report  
CPU-Z version 1.26.  
Number of CPUs 1  
Name Intel Pentium III-M  
Code Name Tualatin  
Specification Intel(R) Pentium(R) III Mobile CPU 1133MHz  
Family / Model / Stepping 6 B 1  
Extended Family / Model 0 0  
Brand ID 6  
Package BGA/Micro-PGA  
Core Stepping tA1  
Technology 0.13 µ  
Supported Instructions Sets MMX, SSE  
CPU Clock Speed 1132.3 MHz  
Clock multiplier x 8.5  
Front Side Bus Frequency 133.2 MHz  
Bus Speed 133.2 MHz  
L1 Data Cache 16 KBytes, 4-way set associative, 32 Bytes line size  
L1 Instruction Cache 16 KBytes, 4-way set associative, 32 Bytes line size  
L2 Cache 512 KBytes, 8-way set associative, 32 Bytes line size  
L2 Latency 0  
L2 Speed 1132.3 MHz (Full)  
L2 Location On Chip  
L2 ECC Check enabled  
L2 Data Prefetch Logic yes  
L2 Bus Width 256 bits  
Mainboard and chipset   
Motherboard manufacturer IBM  
Motherboard model 26474MU, Not Available  
BIOS vendor IBM  
BIOS revision 1AET62WW (1.18 )  
BIOS release date 07/06/2004  
Chipset Intel i830MP rev. A4  
Southbridge Intel 82801CAM (ICH3-M) rev. 1  
DRAM Size 1024 MBytes  
Windows version Microsoft Windows 2000 Professional Service Pack 4 (Build 2195)  
DirectX version 9.0c  
Name S3 Graphics SuperSavage/IXC 1014  
PNP Device ID PCIVEN_5333&DEV_8C2E&SUBSYS_01FC1014&REV_054&74C6020&0&0008  
Adapter Type S3 SuperSavage/IX, S3 Graphics, Inc. compatible  
Adapter Description S3 Graphics SuperSavage/IXC 1014  
Adapter RAM 16.00 MB (16,777,216 bytes)  
Installed Drivers s3ssav.dll  
Driver Version  
INF File oem1.inf (S3SSavage section)  
Color Planes 1  
Color Table Entries 4294967296  
Resolution 1024 x 768 x 60 hertz  
Bits/Pixel 32  
[Sound Device]  
Item Value  
Name Echo Indigo io  
Status OK  
PNP Device ID PCIVEN_1057&DEV_3410&SUBSYS_00A0ECC0&REV_015&7BF34D8&0&0001F0  
IRQ Number 9  
Memory Range 0xFE700000-0xFE7FFFFF  
Driver c:winntsystem32driversechondgo.sys (135424, 6.11)  

i will try the things you wanted me to, along with trying with an external keyboard

You have an Echo soundcard?

Maybe it’s just nothing…
But i remembered this case also, just it was a different model:…c078f18e33d7efd

But you also have DirectX 9.0c

yeah it really does, i cant use renoise without the power adapter. i mean like its not even worth running because of the lag being even worse than it is when its plugged in.

I had similar problems with my fathers new AMD 2800+ which has a feature
called “PowerNow”, probably similar to the “speedstep” on your computer.

Anyway: The PowerNow would make the computer oscillate between
savingpower (CPU=veery slow) and normal (CPU=fast) and it would make
some of the games totally unplayable, as it would lag incredibly sometimes.
I have no idea why only a few games would freak out in this manner though.

This was dont while still on poweradapter and the only way to disable
this fine “feature” was to disable the driver for it in the devicemanager in XP.

After that the computer kicked rump roast.


man i know if mine pooped out id be one depressed being
i’ve spent about $1300 on it so far and everything i use it for “except” renoise works exceptionally.

but i guess what’s really killing me is realizing that in order for me to use renoise i would have to drop 2-4 grand in order to do what i want.
and worse is that im gonna have to wait till probably next year to be able to justify spending that kind of money on a laptop. :(

oh whoops i didnt realize you where saying that kicking rumproast was a good thing until i reread it a forth time hehe
im mos def going to try an find this driver,
“choice crosses finger”


renoise is working better than ever now!
i also have my indigo echo io set on a really low latency setting,

this needs to be put somewhere for others to find if they run into problems using laptops!!!

man this really has made my month

I shall add a general note about performance issues concerning speedstepping cpu’s in the troubleshooting sections…

There you go buddy :D Hows that rump roast now heh? mm deeelish. :dribble:

I’m not quite sure this is the end of it.

i reinstalled xp and went through the usual steps for audio
and what i have discovered might be of some use
it seems when using a standard version of xp pro there isnt any power management drivers installed. (well unless i over looked it somehow)

so i finally got down to business again with renoise
i started on a new tune and i loaded up reaktor
everything was working “Perfect” until i started using Vstiautomate
the problem came back when the selected vsti in Vstiautomate is the instance of reaktor.

so then i started by turning off VstiAutomate -didnt solve it.

then i switched the select vsti number to a different instrument
–the problem stopped!

so then while i wrote this i switched between the installed vsti’ and the only other vsti that did the same thing was z3ta+ so far out of the 5 or 6 plugs i have installed so far.
so i will try some more vsti tomorrow.

if that makes any sense, i guess if the real problem exists in my laptop and not possibly a little tweak of the Vstiautomate Function then at least the “problem be gone button” is just a couple clicks away.