Lag on first note with Kontakt VST


I’ve been having some difficulty with Renoise pausing for a few milliseconds between patterns just after it is loaded. It only seems to be a problem on the first play through the track (and bizarrely enough, only the first time I load up Renoise since starting the laptop), but its really annoying when trying to play live!

Its something I’ve only noticed in 1.9 Beta 5 & 6 (1.9 Beta 4 was the first version I downloaded, and I didn’t notice it in that).

I’m running Renoise on a 1.83GHz Macbook with 2GB Ram on OSX 10.4.10 if that helps at all.



do this happen with a specific VSTi? for example with Kontakt?

Yup, all the songs I’ve done that this have happened to have had Kontakt running. On some it seems to be just before the first note that is played through Kontakt is played. Its version 2.2.3 (i.e. the latest) version of Kontakt which is being run.

Apple -> System Preferences -> Energy Saver -> Options. Change Processor Performance from “Automatic” to “Highest”.

Also known as “PowerStep,” this option on Automatic allows the software to change the microprocessor’s clock speed and/or turn off the L3 cache, slowing down to conserve power or speeding up when more speed is needed.

This “feature” screws up a lot of things for me when using Renoise, specifically recording and VST initialization. The time the computer takes to go from slowdown to speedup causes the hick-up.

In regards to b4, you probably had a bunch of stuff going on i.e. several active processes and other open windows which had the processor maxed out at the time of usage. I doubt it has anything to do with the version of Renoise you were using, more to do with if the processor mode at the time of usage. To avoid the luck of the draw, enable “Highest” instead of “Automatic”


I’ve just had a quick look at the settings in the energy saver menu - theres not an option for changing the processor performance. It is an intel mac - I suppose they don’t have this feature (I’m not very knowledgeable on the subject of macs - recent convert from the pc).

I’ve tried disabling/uninstalling any applications that load on start-up and switching the ‘put hard drives to sleep when possible’ option off. Neither had any effect.

Any other ideas folks?

Cheers again,


Yeah, that feature is for G4/G5 macs. Back to the drawing board.


I’ve mentioned Kontakt because its DFD feature can cause the issue you are experiencing.

try disabling it (of course do this at cost of much higher RAM consumption)

personally, I’m experiencing it too, but since Beta4 the song I’m working on has grown a lot, so it may also be that Beta4 would have had this issue too.

I’ve just tried swapping from ‘DFD’ to ‘Sampler’ within Kontakt. I’m afraid to say it hasn’t worked! I Still get a small gap at the start of the pattern where the Kontakt part kicks in.

Thanks again for the advice and things to try… Please keep it coming!

this is kontakt drum part bug
i have same bug with aodix

So you only get this once when a Kontakt instrument starts the first time, right? Never with samples or VSTis?

Does it maybe make a difference when turning the autosuspend mode off for that instrument? You can do this in the Insturment Settings tab in Renoise for each instrument.

Does it make a difference when turning off the multi processor support in Renoise? You can do this in the Preferences->Audio tab (set number of CPUs to 1).

When you get this delay, the whole GUI and audio freezes for a moment? Is the system or Renoise CPU usage increasing as well at that time?

It seems to only pause the first time the instrument starts. If the track has been loaded and played once already since the laptop has been switched on, the pause seems to go, but the audio quality can suddenly turn pretty aweful when using an external soundcard (Saffire LE) until the interface is re-initialised.

I’ve tried taking out the Kontakt instrument and the pause stops happening. Unfortunately I don’t own many other VSTis to try out. The few freeware ones I have seem to be fine.

I’ve tried this. To my ear the pause seems subjectively shorter, but still there.

Changing the number of CPUs makes no difference unfortunatly.

The GUI does freeze a little - this does seem to happen at other points though. In terms of system usage, I ran activity monitor and the CPU and memory usage stays relatively constant, but the disk usage peaks at that moment. Infact, it touches the top of the activity window.

Thanks for the details. Then this clearly looks like a VST (Kontakt) problem and I don’t think that we could do something to avoid or “fix” this.

But this also means that if you load the samples into RAM, then this problem should go away. Are you sure that you tried loading all relevant samples from this instrument into RAM? Please try to test this again, if this still doesn’t help report this issue to NativeInstrument please.

usually, when I’m 100% sure of a Kontakt instrument part in a song (i.e.: never :)), I use Kontakt sample pool options to purge unused samples, then disable DFD for that instrument. usually this improves playing consistently.

however, to obtain better (= perfect most of times) results when rendering, using the real time mode should improve things even when DFD is active.

Well, I’ve had a reply from Native Instruments technical support. Not exactly what I wanted to hear. Though I paraphrase here, the responce was:

‘If you don’t use Cubase, Nuendo, Logic, Sonar, Pro Tools or Digital Performer, we’re not going to even try to investigate or fix any bugs’.

Not a happy bunny at all. I know there must be thousands of different host programs out there, but at least for Native Instruments to take some interest in the problem would be good.

If there is anyone on here who is having the same problem, since NI aren’t exactly being helpful, I’ve found a bodge fix!

Load a short, silent sample (i.e. 0.1ms of nothing) into Kontakt. Play on the first step of the first pattern and there is no audible pause. Don’t know why I didn’t think of it sooner - its quite obvious really.

Hope someone finds this useful.