Latency issue with sequencer

I’m using the new Korg SQ-64 sequencer with Renoise and got their MIDI clocks synced up. But when I record patterns into Renoise - even if they’re right on the grid in the sequencer - there’s always some delay in the delay column from like 40-70.

I was hoping to use the step offset feature in the SQ to come up with grooves but it’s kind of pointless if everything will be recorded with this long delay added to it anyway.

Any tips?

I had my block size at 256 & 32 and happened both ways.

Could turning off this help?


1 Like

I’ll try it now

Yes this improved it but not exact yet. It’s gone from a 50-7F delay to a 10-30 delay with the first note extra delayed at 97.

I turned the tempo down to 30 BPM to see if that would help but as you can see that makes it even worse. Each of these notes should be landing exactly on the beat with no delay.

I also tried using Renoise as the master sync and not my sequencer with latency compensation on. This produces a 40-50 delay on each note.

I tried using Renoise as the master with latency compensation off and some of the notes hit exact right, some are one line early with an FF delay and some are on beat with an 04-07 delay

Does enabling the quantize icon help when recording?

Yeah it snaps it to the line but I’m hoping to use the sequencers note offset and be able to program notes that are just off-grid in a deliberate way.

Quantize would get rid of those offsets.

I’ve successfully got the sequencer to record exact on the grid in MPC. I guess I could do everything in MPC and use the MPC VST to record my songs into renoise, but it’ll be quite a hassle.

I’ve finally got it to work, or at least now it’s recording notes with a delay of 01 or 02 which is usable to me.

  1. Turn off latency compensation
  2. Make Renoise the MIDI clock master
  3. Turn the tempo down to 32 (the lowest Renoise allows) when recording
  4. Try to record multiple tracks at once from the SQ-64. By doing this I even got one take to hit exactly on beat every beat with no delay at all! Don’t know why it matters.

Looks like I spoke too soon. My workarounds only work with an LPB of 4. Turn it up any higher and everything syncs wrong, getting later and later each time it loops as before. Unfortunately I need my triplets and short notes.

Doesn’t seem to be a way to record my sequencer into phrases either since it’s a separate play button so I’m just stuck unable to use my sequencer with Renoise.