Linux 64Bit: Some Vsts Are Not Working

Hi there everyone!

I have made a pack of some Linux VSTs I collected from several sources.
I only add the ones I found stable, so they don’t crash the host.

When tested on 32bit renoise they worked fine.
But… when renoise 64bit for linux came out, I went to do some testing… and found out that not a single plugin worked!

Here’s the link to my pack:

It contains source code, 32bit and 64bit linux binaries.

What I found out so far:
-> 32bit versions work fine on any host (jost, energyXT, qtractor and renoise)
They make noise and can show/hide the GUI correctly.
-> 64bit versions kinda work on qtractor (the only other host able to run 64bit VSTs; I wasnt able to compile jost…)
Qtractor is not the most stable app, so it can crash sometimes. I compiled it with the official headers, not the vestige one.
It crashes when showing the GUI though…
-> 64bit plugins: renoise is able to get the plugin’s name and vendor but not the unique id (always -1).
they all appear as effects, and nothing works… If I try to change the current plugin preset, renoise says the plugin crashed…

What I found strange here is:
-> all other 64bit vst plugins work fine (mda, axonlib, etc)
-> the code and compile flags are exactly the same (except “-m32” or “-m64” for changing architecture)

I’m not sure if this is my fault or whatever, but I guess I should just ask the pros what they think…
Any help here is appreciated


I’ve been investigating the same thing myself, and the solution appears fairly straightforward: use vstsdk 2.4. I’ve witnessed exactly the same problems (all plugins being classed as effects, and no external editor), and fixed it by building against the newer sdk.


I’ll try it and report back ASAP

The code seems completely incompatible…

I’ll look more deep into this once I have more free time, but I’m not sure I’ll be able to fix this…

Any suggestions?

Afraid not: In my situation (using the JUCE library) it was simply a case of changing a #define to build against VSTSDK 2.4. If I get some spare time this weekend, I’ll see if I can delve a bit deeper…

It seems that the VSTSDK2.3 is just not 64bit friendly (using 'long’s).

ah well… I’ll have to port the old plugins…


hah i just figured out why vst pack from kxstudio work partially and tried to recompile loser exiter with vstsdk 2.4. After some mess with sources i made it compiled, but not workin.

and yes, only vstsdk 2.4> has 64bit support

i wish azr3 would work in 64