Linux Audio Problem

I have the same problem with jackd. All my other apps that use jack are 64-bit, and jack itself is 64-bit. For now I’m running renoise in a vm… A horrible solution, but I just got this new desktop, so it can handle it. What new computers out are still 32-bit? Netbooks? Even my new laptop has two cores, and 4 gigs of ram…

a VM is not necessary; you should use the ia32-lib libraries in order to run Renoise into a 64-bit environment.

in particular, you need the 32bit versions of:
libc6 – GLIBC 2.3.6 or newer 7.1 or newer
libstdc++6 – GNU Standard C++ Library 4.2 or newer
libasound2 – ALSA library 1.0 or newer

Well, the only other app I use that is 32 bit is Skype, so I just installed the older 32 bit version of ubuntu studio that has the rt kernel and now renoise doesn’t whine about audio and I can still use the audio of other programs. Renoise is relatively light on my CPU, so the VM overhead isn’t too much.

I’d obviously rather have a 64bit renoise that linked against 64bit jack, but I don’t have it yet. I choose a VM over quitting every app that has tried to use audio before I use renoise with alsa. Oh, I could always run renoise as root!!.. Give me a break :confused:

Alsa locking problem is fixed in the latest beta version. Still no luck with 64bit jack though.

I cannot confirm on Debian Testing. Did you maybe change something into your ALSA configuration recently?