Linux Audio Problem

i use ubuntu studio 8.04 and have renoise running through ALSA and realtime (not through JACK -> noisy glitchy sound). i now have the problem that i can’t run 2 renoise songs at the same time. and when renoise is open i can’t play other audio (outside renoise). how can i fix this?

I have the same problem with ALSA, but I really haven’t found a solution for this: I can mix audio from different sources given that one of these sources is not Renoise. This does not occur to every user, though, because forum user NeuRoTiX is able to mix Renoise with other sources.

yeah it sucks. because mostly i have renoise files open and audacity. but in ubuntu it doesn’t work :angry:

i discovered another problem today. i can’t record in audacity. the only thing i get is cracks and noises. tried to select other devices in volume control, etc. but nothing works. do you have any idea how i could fix this?

damn i was so happy renoise finally worked and now this, they should seriously make it easier for musicians to use linux.

Same problem. Renoise hogs the whole device and doesn’t let anything else use it. Also renoise fails to launch with alsa if any other apps are open that are using alsa - amarok, audacity, etc.

Haven’t found a workaround, hope it’s fixed soon in a new release, I consider this a large bug. I’m using opensuse 11.1.

Renoise open the ALSA device in hardware blocking mode (hw:0.0) to minimize latency so you can’t open a second ALSA app.
You’re only solution at the moment is to use JACK.

I’d like to have the choice to select whatever ALSA device is declared in asound.rc (like my default dmix based which work in any other audio apps)

but when i use jack i have the same problem + i get glitchy/noisy sound in renoise. i also have some other audio issues in ubuntu studio…

  • when i record something from the line-in/mic input i only get small cracks but no sound. (i thought it was audacity’s fould but get the same thing in ardour).
    -when i plug in my headphones, the internal speakers from my laptop keep working.

hope anyone can help me.

about your first problem:

quoting from here:

about your second problem:
check out in the Ubuntu preferences (should be System => Preferences => Audio; there should be a way to lower the volume of the speakers. I had Ubuntu in the past on my laptop and with a combination of sound levels in the preferences I managed to solve this problem, but I can’t recall what the setting was.

i never tried to record inside renoise. i actually meant that i want to record my line-in signal inside audacity (or something else, 'cause i heard audacity is buggy in ubuntu). this worked perfectly when i was still using Vista. but in ubuntu studio i can’t get it working nomatter what option i select. either get no sound or noisy cracks.

didn’t found ‘audio’ in preferences. if you meant ‘sound’ than i don’t really understand how it could solve this. man, sorry for all the questions but i find ubuntu really hard. i just want to make beats you know. the last week i’ve done nothing else than google my *** off and it’s still not working like it should.

Maybe you should consider to go with Jack when you are under Linux.
From my point of view, music under linux without Jack is like christmas without gifts…

If you have the ubuntu 8.04, you should try to install some packages with
http://ubuntufromscratch.wordpress.com/le-…mscratch-hardy/

It’s in french but you have the last version of jack and alsa in and alsa out precompiled. It can help!

The only thing that i can say about Ubuntu Studio is that i still have 7.10 and no problems with that distribution on my PC.
Whether it works on a laptop i don’t know, but perhaps you could try downgrading to 7.10 or at least a version prior to 8.00.
I have yet to read a good reason to upgrade, so far the best that i heard about Ubuntu 8 is that the latest update runs stable but is still running sluggish compared to 7.10. imho that is still worse and not worth upgrading.

does 7.10 already has a rt-kernel? or doesn’t it have the problems i get with ALSA?

how can i use jack without it fucking up my sound in renoise?

I believe i downloaded the RT-kernel for Ubuntu (studio) 7.10, there is a method to install it. IT-alien has posted this line a few times on the board, though my office pc browser acts funny with the javascripts of this board which complicates the search for me. i’ll look it up tonight.

ok, i can finally run Renoise decently through Jackd. i can also play something in Ardour while Renoise is open. i can also record in Ardour. i can only use the mic-input for recording, but it’s sensible for overdrive. is there a way i could use the line-in instead?
also the Jack icon turns red when i play something for the first time and stays red. what does this mean? how do i stop this from happening?
i still have the problem that my internal laptopspeakers don’t mute when i plug in headphones. any solutions?

I can’t get renoise to work with jack because of 32bit/64bit problems. Using jack would be much better than using alsa. It’s a shame, right now I can’t really use renoise properly with either. I’d need either a 64bit renoise version to use with 64bit jackd (this post), or a version that doesn’t lock alsa. :(

You can also compile a 32-bit Jackd (compile using the 32bit compatability flag i mean), then your problem is over as well. It only becomes a problem if you want to connect Renoise to another 64-bit host that requires 64-bit jack.

Hi from Here!! :guitar:

Since Ubuntu 8.04, the new pulse audio server is installed…and it is a really bad audio server, full of bugs. It is I think the source of your troubles.

You can not remove it, and when you try to remove it, it makes many troubles in the system…

The best Ubuntu is the 7.10, you can install and custom everything for the best performances.

You can install 64studio distrib (based on Debian Etch), maybe the best choice.

Peace!!

BreemiX

:drummer:

All of my other apps that use jack are 64bit, unfortunately. There are 32bit libs for jack available on my distro’s (opensuse) repos, and I have those installed, but the jackd executable itself loads the 64bit libs (in /usr/lib64/jack), not the 32bit ones (in /usr/lib/jack). There’s no cl parameter to point jackd to the driver location specifically. The binaries are probably not compatible like that anyways, symlinking the 32bit libs into the 64bit dir doesn’t work. I’ve tried everything I can think of. There’s no solution for me until the developers put out a new version, hopefully soon.

i have the same problem in linux mint 6

I have the same problem too (+101 other problems) with Ubuntu studio 8.04 and I’m loosing it… :panic: :panic: :panic: :panic:
It seems hopeless.

Everything else works great or well enough for me, but when it comes to audio, then I just feel like

I had a million problems with 8.04 and 8.10 too but re-installed 7.10, the realtime kernel, jack and everything and it’s working all right.