Linux: Changing Locked Memory Limit

Hey guys, I’m relatively new to Renoise in a professional sense. I am running 32bit Ubuntu Linux 12.04.

I Was trying to load a WAV sample of vocals I recorded, but I keep getting an error that says “Out of Memory!” and says to check locked memory limit. Well, I have done this and realized that Renoise has a locked memory limit of 64:

core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 0
file size (blocks, -f) unlimited
pending signals (-i) 31067
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 31067
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited

I have tried changing this with the ulimit command:

$ ulimit -l unlimited && renoise

which yields the error:

bash: ulimit: max locked memory: cannot modify limit: Operation not permitted

I just want to be able to edit a damn sample without having to reconfigure my entire system! Anyone know how I can maybe fix this?

This is a known issue, see here: Hard Disk Load

If you have a lot of vocal samples I suggest you Rewire your project to Reaper.

sorry for the silly question: have you tried running this command with sudo?

also: it would be good if you use a task manager such as gnome-system-monitor in order to understand how much ram is actually used and available. Using the 64 bit version, if possible, would be much better if a lot of RAM is used

Renoise can’t do this for you. But you can unlock memory via the /etc/security/limits.conf file.

See for more info about limits.conf.

@audio - rtprio 99  
@audio - memlock unlimited  
@audio - nice -10  

And add yourself to the “audio” group.

Or use:

YOURUSERNAME - rtprio 99  
YOURUSERNAME - memlock unlimited  
YOURUSERNAME - nice -10  

Yea, I have used sudo to no avail. Meh, I tried just importing to Ardour then exporting as a WAV file again which seems to work for some reason… regardless of whether or not it was already a WAV file.