Linux: Delay column for MIDI notes - FF delay is not short before next beat

I’m on Linux with the Renoise 3.2 Demo.
When I record MIDI (ESI M8U XL) and the notes are short before the next bar, the delay is recorded as FF.
This is what should happen and while recording it also sounds as expected.
When it is played back from the recorded notes in Renoise, the delay is different though, a lot less then needed. So the notes with FF delay are not delayed enough to appear just before the next bar, they appear a lot earlier.

E.g. if I put a note with FF delay before a note in the next bar (without delay), they should be very close in time (approx. a 256th fraction of the time of one line to the next). But it is obviously a lot longer, more like half as needed.
I tried different settings but always got the same issue.

When reording MIDI it means that all notes being played a bit ahead in time will appear much to early in time. Or the other way around, I can not place MIDI notes to be a little ahead in time using the delay column. This is also happening if I type the notes in and do not record via MIDI.

Is the MIDI that you are playing in Renoise a “real” external MIDI device or some internal MIDI routing?

Is the delay column working at all for this MIDI instrument? Does it have any effect or is the delay just too small?

We’re using the ALSA sequencer scheduler to “delay” MIDI events. This delay mechanism may be implemented/applied by the ALSA driver and thus may be broken too.

Thank you for looking into this!

It is a real MIDI instrument. I tried an Akai S6000, but also other instruments show the same problem.
The delay is delaying, so it does have an effect, but it is not enough.

If I put a note at FF delay and one right in the next step with 00 delay using the delay column, i hear a quite long distance. So it is a lot more than from 00 to 01 delay for instance.

If I do not use the delay column, but the FX command 0QFF instead, the delay is correct! So if this is using ALSA, then there is maybe a problem handing it over to ALSA in the delay column vs. the FX column.

When I record notes I have to move all delays for MIDI to the FX column which makes the delay column kind of useless.

I checked more into it and recorded a video:

I am running the 3.2.1 demo on linux.
In the video you can see and hear the delay column is not delaying at all. The FX column is working correctly.
The only thing going on in that project is one track triggering an Akai S6000 with a short sample.
I kept the speed high so it is very easy to hear the difference.

I tried all kind of values in the delay column and it seems to have actually no effect at all.
I also changed the LPB und buffer settings and switching realtime on/off all has no effect at all (the delay column does not work).
I could live with working with the FX column, but when I record notes, the delay column is used and not the FX column.
I hope this helps finding the bug!

Hi @taktik,
this is still an issue with the paid version of Renoise 3.2.1 on Linux.
I can answer your question with “the delay column does not have any effect at all”. In fact, even in the MIDI output window of Renoise, it shows no effect.

I tried this test pattern, where C-7 plays with a delay of F0, and C-8 plays at the same step with a delay of 00.
In the MIDI output window, Renoise shows both events with the very same time stamp (and in fact, they sound at the same time, even if C-7 should be delayed by almost one step).

With a sample-based instrument, the correct behaviour can be heard.

The MIDI output window (please ignore everything except “DeepMind12 MIDI 1”. Below: the test pattern
The test pattern

Is this a bug or am I holding it wrong?

please note, that Qxx in the effect column does work for MIDI. Unfortunately though, live recording does not create Qxx effects, and also they seem to not support multiple notes per row, do they?

@Windfisch sorry for the very late reply, but I just found out by accident what the problem is.

There’s a hidden option in the Renoise preferences to enable/disable the ALSA MIDI scheduler. This option got added for internal use only, and should be enabled by default. But for some reason it is disabled by default, but never was here while testing, so I also never could replicate the problem.

We’ll fix this in an upcoming update to enable it again by default. Until then you can do the following:

  • open Renoise
  • click on the “Help” -> “Show the Preferences Folder menu…”
  • Close Renoise again
  • open the “config.xml” file in the revealed folder in a text editor
  • set <EnableAlsaMidiScheduler> to true
  • save the file and open Renoise again
1 Like